View Issue Details

IDProjectCategoryView StatusLast Update
0028816LazarusLCLpublic2016-07-19 00:13
Reporterwsoft-huAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLazarus 1.4.4 FPC 2.6.4OSWindows 10OS Version10
Product Version1.4.4Product Build- 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0028816: dbgrid cellhint
Descriptionshow | symbol in statusbar if cellhint is true and dbgrid hint properties |text...
TagsNo tags attached.
Fixed in Revision52705
LazTarget1.8
WidgetsetWin32/Win64
Attached Files

Activities

wsoft-hu

2015-10-10 07:27

reporter  

Képkivágás.PNG (2,494 bytes)
Képkivágás.PNG (2,494 bytes)

Bart Broersma

2015-10-11 12:16

developer   ~0086430

What exactly are you trying to say here?

If you are unsure about how to frase it in English then you can add a description (alongside an attampt in English) in your native language.
Someone else will then understand the problem you are describing.

wp

2015-10-11 12:34

developer  

grid-cellhints.zip (2,124 bytes)

wp

2015-10-11 12:38

developer   ~0086435

Last edited: 2015-10-11 12:39

View 2 revisions

I think he means that the "long" part of the cell hint which is displayed in the status line if the cell hint text contains a bar character ("|") is not extracted correctly. Please see my demo (grid-cellhints): cell "a1" has a hint text "short a1|long a1". The part before the bar ("short a1") is displayed correctly in the hint popup, but the part after the bar ("long a1") is not shown in the status bar - the status bar shows the complete hint text instead.

wp

2015-10-11 23:38

developer   ~0086476

Last edited: 2015-10-11 23:40

View 2 revisions

I played with the hints a bit. It seems that the "long" hint must be assigned to the Application.Hint, not the total hint.

I would have liked to submit a patch, but my local version of grids.pas stills contains changes due to another unapplied patch (0028755). But the change required here is only a 1-liner:

- In grids.pas, seek procedure "TCustomGrid.ShowCellHintWindow"
- Near its end, there is the line "Application.Hint := AppHint".
- Change this to "Application.Hint := GetLongHint(AppHint)".

The attached modified demo shows combined (short+long), short only and long only hints and allows to compare the standard behavior of buttons with the cell hints of a grid. Both types behave in the same way now.

wp

2015-10-11 23:39

developer  

grid-cellhints-new.zip (2,221 bytes)

Bart Broersma

2015-10-11 23:55

developer   ~0086479

Maybe I'm to blame. IIRC I fiddled with that code in the past.

wsoft-hu

2015-10-12 06:29

reporter   ~0086482

ha a táblázat hint tulajdonsága valami|valami a statusbarban a | jel megjelenik

If the table hint feature something | some of the Statusbar | sign appears

wsoft-hu

2015-10-12 06:29

reporter  

dbgrid.zip (128,340 bytes)

Jesus Reyes

2016-07-17 21:21

developer   ~0093744

Applied the described patch, thanks.

Issue History

Date Modified Username Field Change
2015-10-10 07:27 wsoft-hu New Issue
2015-10-10 07:27 wsoft-hu File Added: Képkivágás.PNG
2015-10-11 12:16 Bart Broersma LazTarget => -
2015-10-11 12:16 Bart Broersma Note Added: 0086430
2015-10-11 12:16 Bart Broersma Status new => feedback
2015-10-11 12:34 wp File Added: grid-cellhints.zip
2015-10-11 12:38 wp Note Added: 0086435
2015-10-11 12:39 wp Note Edited: 0086435 View Revisions
2015-10-11 23:38 wp Note Added: 0086476
2015-10-11 23:39 wp File Added: grid-cellhints-new.zip
2015-10-11 23:40 wp Note Edited: 0086476 View Revisions
2015-10-11 23:41 wp Assigned To => Jesus Reyes
2015-10-11 23:41 wp Status feedback => assigned
2015-10-11 23:55 Bart Broersma Note Added: 0086479
2015-10-12 06:29 wsoft-hu Note Added: 0086482
2015-10-12 06:29 wsoft-hu File Added: dbgrid.zip
2016-07-17 21:21 Jesus Reyes Fixed in Revision => 52705
2016-07-17 21:21 Jesus Reyes LazTarget - => 1.8
2016-07-17 21:21 Jesus Reyes Note Added: 0093744
2016-07-17 21:21 Jesus Reyes Status assigned => resolved
2016-07-17 21:21 Jesus Reyes Fixed in Version => 1.7 (SVN)
2016-07-17 21:21 Jesus Reyes Resolution open => fixed
2016-07-17 21:21 Jesus Reyes Target Version => 1.8