View Issue Details

IDProjectCategoryView StatusLast Update
0028823LazarusIDEpublic2015-10-30 14:42
ReporterJulian PuhlAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSOS Version
Product Version1.5 (SVN)Product Build 
Target VersionFixed in Version1.5 (SVN) 
Summary0028823: [Regression] Anchordocking: Unable to move docked window into tab
DescriptionWhen you try to dock a window to the center of a target window, this never works. The selection always jumps to one of the borders.

Using Lazarus 1.4.2 this works flawlessly. The selection jumps to the center of the window and if you stop pressing the mouse button, the window has now tabs and you can choose between both.
TagsNo tags attached.
Fixed in Revision50199
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0028704 resolvedJuha Manninen Anchordocking design does not save settings 

Activities

Julian Puhl

2015-10-11 16:34

reporter   ~0086450

I am not sure what is going on here. Maybe it has something to do with old settings. First my IDE forgets all docking settings and I have to rearrange everything. The speedbuttons (run etc) are gone. If I select to show them the bar is empty. After several restarts they show up, but I can't move the windows into tabs like described above.

Now after several restarts (and again missing buttons) everything including the tab stuff works as if nothing happened, but the options for anchordocking have been reseted.

Juha Manninen

2015-10-11 17:00

developer   ~0086454

Environment options configuration has been revamped. It now supports a collection of desktops. Window placements and many other things are part of a desktop.
Some intermediate versions may have broken your configuration. Try with a new one either by removing the local config dir or by using --pcp parameter for Lazarus.

Julian Puhl

2015-10-11 19:38

reporter   ~0086465

With a new config the problem remains. I even deleted all non versioned files and did a make clean. As soon as I install anchordocking, the buttons are gone until restart and you have the issue with the tabs. Revision is 50032.

I update from time to time and never had any problems. The last revision I used was from a few days ago.

Ondrej Pokorny

2015-10-11 20:10

developer   ~0086468

>> Now after several restarts (and again missing buttons) everything including the tab stuff works as if nothing happened, but the options for anchordocking have been reseted.

Run (Main Menu) -> Tools -> Desktops. Do you have the "Auto save active desktop" check box checked?

Julian Puhl

2015-10-11 20:28

reporter   ~0086470

Yes, it is checked.

Julian Puhl

2015-10-18 13:46

reporter   ~0086666

If you remove PageAreaInPercent="0" from <Settings/> of <AnchorDocking> in the environmentoptions.xml, everything works again. Maybe the value which gets written when creating a new config is wrong?

Luckily I had a backup of my old config, so the reset did not matter to me. This one still works. I have to idea why lazarus decided to lose the settings.

Juha Manninen

2015-10-28 18:09

developer   ~0086950

Can you still reproduce using a configuration from your 1.4.2 release version?
If not, I will resolve this as "Unable to reproduce".

Julian Puhl

2015-10-28 22:57

reporter   ~0086964

Lazarus 1.4.2 does not yet have the anchordocking configuration in the environmentoptions.xml. Thus everything works there.

I have asked a friend to verify my issue. He has the same behavior as I have. We both use newest lazarus + fpc svn trunk version.

If you let lazarus create a new config after you run make (just renaming/deleting the configuration folder breaks the package list), you get a broken anchordocking configuration. You need to deselect "locked" and select "show headers". After that you have the issue with the tabs. If you let lazarus save the configuration, the line in the xml file is:

<Settings DragThreshold="0" DockOutsideMargin="0" DockParentMargin="0" PageAreaInPercent="0" HeaderAlignTop="-1" HeaderAlignLeft="0" ScaleOnResize="False" ShowHeaderCaption="False" HideHeaderCaptionFloatingControl="False" HeaderFlatten="False" HeaderFilled="False"/>

P.S.:
I know this a mantis issue and has no place here, but losing all my texts because of "Invalid security token" is really annoying. At least the text could be saved somehow. Going back does not work here as it normally would. I don't always remember to copy the text before posting.

Julian Puhl

2015-10-28 23:29

reporter   ~0086966

Just to be really sure: Building with fpc 3.0 rc2 doesn't change a thing.

Ondrej Pokorny

2015-10-29 07:48

developer   ~0086969

>> I know this a mantis issue and has no place here, but losing all my texts because of "Invalid security token" is really annoying. At least the text could be saved somehow. Going back does not work here as it normally would. I don't always remember to copy the text before posting.

Yes, this is annoying. Use Opera as a temporary workaround- it remembers the text when you hit "Back".

Ondrej Pokorny

2015-10-29 08:58

developer   ~0086970

Last edited: 2015-10-29 09:01

View 2 revisions

Back to the original problem:

It has nothing to do with the configuration storage change.
The change was made in r49757.
I tested 49754 and 49758 and both are OK.

With current trunk (50194), I cannot do anything - I cannot dock/undock any windows at all. AnchorDocking seems to be broken.

Julian Puhl

2015-10-29 10:18

reporter   ~0086975

Last edited: 2015-10-29 10:22

View 2 revisions

Have you unchecked "Locked" and selected "Show headers"? You see a header at the object inspector and can right click on it. After that at least some docking works.

Also thanks for the tip with opera. I will try that out.

Ondrej Pokorny

2015-10-29 10:31

developer   ~0086976

Last edited: 2015-10-29 10:31

View 2 revisions

>> Have you unchecked "Locked" and selected "Show headers"? You see a header at the object inspector and can right click on it. After that at least some docking works.

Thanks, this was it. I don't know why the settings got lost.

-> I can reproduce the problem. Docking into the center of another window to create a docked tab doesn't work anymore (= is not available). All I know is that it worked in r49758.

Julian Puhl

2015-10-29 10:51

reporter   ~0086977

If you remove the <Settings [...]/> completely, you get the default settings for anchordocking. Maybe just don't write them at all? Changing settings creates the xml node again with the changed option(s).

Juha Manninen

2015-10-29 11:01

developer   ~0086979

Last edited: 2015-10-29 12:38

View 2 revisions

> With current trunk (50194), I cannot do anything - I cannot dock/undock any windows at all. AnchorDocking seems to be broken.

Oh, I thought it was only me and my XFCE. I tried to bisect the bad commit. Going to August, it worked. Coming back to the future, I mean present time, and it still works. Deleting local config and regenerating it, and it is broken again.
This is caused by writing fresh configuration. Bisecting more ...

BTW, Firefox 41.0.2 on Xubuntu has learned to remember text after "Back". I used to have the same problem and switched to Qupzilla.
Now I have Xubuntu and its new Firefox behaves better.

Juha Manninen

2015-10-29 11:49

developer   ~0086984

Anchordocking stopped working with fresh configuration by r49895 :
 IDE: Improve saving Anchordocking settings. Issue 0028704, patch from Ondrej Pokorny.

I must assign this to Ondrej, my knowledge is not enough.

Ondrej Pokorny

2015-10-29 16:55

developer   ~0086997

Now legacy (or default) configuration should be loaded when anchordocking is installed the first time. Please note that if you already have saved a desktop with corrupted anchordocking configuration, you probably won't see any change.

Test and close if OK.

Julian Puhl

2015-10-30 10:09

reporter   ~0087007

Yes, now it works correctly. Thanks.

Now only the IDE-Coolbar (Run, Pause etc) is gone after restart. Shall I open a different issue for that?

Ondrej Pokorny

2015-10-30 11:18

developer   ~0087009

>> Now only the IDE-Coolbar (Run, Pause etc) is gone after restart. Shall I open a different issue for that?

Yes, if you think it is a bug. But add more information about it and how to reproduce it. I could not reproduce. IDECoolbar is correctly loaded from desktop settings after reset of my IDE.

Are you sure you saved your desktop?

Juha Manninen

2015-10-30 12:02

developer   ~0087013

Julian Puhl, please test also with clean local configuration, either by removing the current one or by starting Lazarus with --pcp parameter.

Julian Puhl

2015-10-30 12:12

reporter   ~0087014

It happens right after I compile for anchordocking package installation. The IDE automatically restarts and the coolbar is gone. I already hat this problem when I opened this issue and you can find it in my first post. Only the issue with the empty coolbar is gone (which probably was because of partially old config).

Julian Puhl

2015-10-30 12:14

reporter   ~0087016

Last edited: 2015-10-30 12:16

View 2 revisions

@Juha: I did a complete rebuild with make clean and make bigide and I deleted the config. I have a lazarus.cfg with --primary-config-path=[...] so it stores the config in the specified folder.

Ondrej Pokorny

2015-10-30 14:00

developer   ~0087023

@Julian: I deleted environmentoptions.xml, anchordocklayout.xml and anchordockoptions.xml and the IDECoolbar configuration works flawlessly.

Nevertheless, IDECoolbar doesn't have anything in common with AnchorDocking, so if you think it is a valid reproducible bug it is a different issue.

IMO you have saved a desktop without IDECoolbar and you don't have checked "Auto save active desktop" in Desktop manager.

Julian Puhl

2015-10-30 14:42

reporter   ~0087030

I am not so sure whether it is unrelated. The "Auto save active desktop" option is checked by default in the newly generated config. Also I always delete the complete folder. The "<Desktop2 Name="default docked" DockMaster="TIDEAnchorDockMaster">" entry contains the values:

<IDECoolBarOptions>
 <Visible Value="False"/>
 <GrabStyle Value="0"/>
 <BorderStyle Value="0"/>
</IDECoolBarOptions>

Which is why it is not visible. Nevertheless I think it is better to close this issue und create a new one.

Julian Puhl

2015-10-30 14:42

reporter   ~0087031

Original problem seems to be fixed.

Issue History

Date Modified Username Field Change
2015-10-11 13:36 Julian Puhl New Issue
2015-10-11 16:34 Julian Puhl Note Added: 0086450
2015-10-11 17:00 Juha Manninen Note Added: 0086454
2015-10-11 17:00 Juha Manninen Assigned To => Juha Manninen
2015-10-11 17:00 Juha Manninen Status new => assigned
2015-10-11 19:38 Julian Puhl Note Added: 0086465
2015-10-11 20:10 Ondrej Pokorny Note Added: 0086468
2015-10-11 20:28 Julian Puhl Note Added: 0086470
2015-10-18 13:46 Julian Puhl Note Added: 0086666
2015-10-28 18:09 Juha Manninen LazTarget => -
2015-10-28 18:09 Juha Manninen Note Added: 0086950
2015-10-28 18:09 Juha Manninen Status assigned => feedback
2015-10-28 22:57 Julian Puhl Note Added: 0086964
2015-10-28 22:57 Julian Puhl Status feedback => assigned
2015-10-28 23:29 Julian Puhl Note Added: 0086966
2015-10-29 07:48 Ondrej Pokorny Note Added: 0086969
2015-10-29 08:58 Ondrej Pokorny Note Added: 0086970
2015-10-29 09:01 Ondrej Pokorny Note Edited: 0086970 View Revisions
2015-10-29 10:18 Julian Puhl Note Added: 0086975
2015-10-29 10:22 Julian Puhl Note Edited: 0086975 View Revisions
2015-10-29 10:31 Ondrej Pokorny Note Added: 0086976
2015-10-29 10:31 Ondrej Pokorny Note Edited: 0086976 View Revisions
2015-10-29 10:51 Julian Puhl Note Added: 0086977
2015-10-29 11:01 Juha Manninen Note Added: 0086979
2015-10-29 11:49 Juha Manninen Note Added: 0086984
2015-10-29 11:49 Juha Manninen Relationship added related to 0028704
2015-10-29 11:50 Juha Manninen Assigned To Juha Manninen => Ondrej Pokorny
2015-10-29 12:38 Juha Manninen Note Edited: 0086979 View Revisions
2015-10-29 16:55 Ondrej Pokorny Fixed in Revision => 50199
2015-10-29 16:55 Ondrej Pokorny Note Added: 0086997
2015-10-29 16:55 Ondrej Pokorny Status assigned => resolved
2015-10-29 16:55 Ondrej Pokorny Fixed in Version => 1.5 (SVN)
2015-10-29 16:55 Ondrej Pokorny Resolution open => fixed
2015-10-30 10:09 Julian Puhl Note Added: 0087007
2015-10-30 11:18 Ondrej Pokorny Note Added: 0087009
2015-10-30 12:02 Juha Manninen Note Added: 0087013
2015-10-30 12:12 Julian Puhl Note Added: 0087014
2015-10-30 12:14 Julian Puhl Note Added: 0087016
2015-10-30 12:16 Julian Puhl Note Edited: 0087016 View Revisions
2015-10-30 14:00 Ondrej Pokorny Note Added: 0087023
2015-10-30 14:42 Julian Puhl Note Added: 0087030
2015-10-30 14:42 Julian Puhl Note Added: 0087031
2015-10-30 14:42 Julian Puhl Status resolved => closed