View Issue Details

IDProjectCategoryView StatusLast Update
0028875LazarusIDEpublic2016-01-21 12:56
ReporterCyraxAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindows OSServer 2008 R2OS Version6.1.7601 (SP1)
Product Version1.5 (SVN)Product Buildr50094 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0028875: [Codetools] Advanced records and class operators : Doing "Complete Code" gives "Error: procedure redefined (first at X,Y)"
DescriptionSee Summary, Steps To Reproduce and Additional Information fields in this bug report for more info.
Steps To Reproduce1. Open attached project in Lazarus.
2. Go to line 23.
3. Press Ctrl+Shift+C ("Complete Code").
Additional InformationLazarus revision 50094
FPC revision 32066
 
FPC make commands:
clean
all
install
OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -XX -CX -dTEST_WIN32_SEH
COMPILER_OPTIONS=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -XX -CX -dTEST_WIN32_SEH
INSTALL_PREFIX=F:\free_pascal_and_lazarus\fpc\i386\trunk\binary\fpc_trunk
UPXPROG=echo
IDE=1
REVSTR=32066
ALLOW_WARNINGS=1
NOWPOCYCLE=1
 
Lazarus make commands:
clean
all
OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -gh -O- -OoNO -Xs- -Si- -vb -XX -CX -dTEST_WIN32_SEH -dHEAPTRC_WINDOW -dDBG_WITH_DEBUGGER_DEBUG
UPXPROG=echo
USESVN2REVISIONINC=0
Tagscodetools
Fixed in Revision51363
LazTarget1.8
Widgetset
Attached Files

Relationships

duplicate of 0029430 resolvedOndrej Pokorny Lazarus CodeTools choke on operators that are only overloaded by result type 
related to 0029459 new FPC Compiler fails on operator result type overloads 

Activities

Cyrax

2015-10-18 06:49

reporter  

project1.zip (1,504 bytes)

Cyrax

2016-01-10 05:39

reporter   ~0088753

This is still a problem...

---

Lazarus revision 51229 
FPC revision 32890 
 
FPC make commands: 
clean
all
install
OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -dTEST_WIN32_SEH
COMPILER_OPTIONS=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -dTEST_WIN32_SEH
OS_TARGET=win32
CPU_TARGET=i386
REVSTR=32890
UPXPROG=echo
IDE=1
NOWPOCYCLE=1
INSTALL_PREFIX=f:\free_pascal_and_lazarus_new4\fpc\i386\win32\binary\3.1.1\fpc_trunk\trunk
 
Lazarus make commands: 
clean
all
OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -gh -O- -Si- -vb -dHEAPTRC_WINDOW -dDBG_WITH_DEBUGGER_DEBUG
UPXPROG=echo
USESVN2REVISIONINC=0

Ondrej Pokorny

2016-01-21 03:41

reporter   ~0089140

Please test.

Ondrej Pokorny

2016-01-21 04:12

reporter   ~0089141

Btw. please supply relevant information only. Your "Description" is generally useless and "Additional Information" isn't relevant for this issue either. Furthermore I don't understand why you supplied the same make commands again in your comment if only revision numbers changed (regardless of the fact that make commands are irrelevant anyway).

It is hard to find relevant information if you supply lots of garbage. Making your reports short but informative increases chances that they'll be looked at.

Cyrax

2016-01-21 09:22

reporter   ~0089144

I'm trying to make my reports short and informative at the same time. Plus I'm supplying information how to reproduce the bug accurately. Namely test project(s) and options how to build those projects. Also English isn't my native language.

Also which options I did use to build FPC + Lazarus environment are relevant too. Those options are critical how (and which way) FPC generates executable binaries and how it relates to bugs.

Anyhow, thanks for your work. I will close this report when I have tested new revision thoroughly.

Ondrej Pokorny

2016-01-21 09:29

reporter   ~0089145

>> Also which options I did use to build FPC + Lazarus environment are relevant too.

Not if you are reporting missing features :)

Anyway, thanks for reporting! Please do so in the future as well!

Cyrax

2016-01-21 12:56

reporter   ~0089150

Seems to be fixed. Thanks for fixing this! :)

Issue History

Date Modified Username Field Change
2015-10-18 06:49 Cyrax New Issue
2015-10-18 06:49 Cyrax File Added: project1.zip
2015-10-18 06:49 Cyrax Tag Attached: codetools
2015-10-18 13:39 Mattias Gaertner Assigned To => Mattias Gaertner
2015-10-18 13:39 Mattias Gaertner Status new => assigned
2016-01-10 05:39 Cyrax Note Added: 0088753
2016-01-17 14:02 Mattias Gaertner Relationship added duplicate of 0029430
2016-01-21 02:11 Ondrej Pokorny Relationship added related to 0029459
2016-01-21 03:41 Ondrej Pokorny Fixed in Revision => 51363
2016-01-21 03:41 Ondrej Pokorny LazTarget => 1.8
2016-01-21 03:41 Ondrej Pokorny Widgetset Win32/Win64 =>
2016-01-21 03:41 Ondrej Pokorny Note Added: 0089140
2016-01-21 03:41 Ondrej Pokorny Status assigned => resolved
2016-01-21 03:41 Ondrej Pokorny Fixed in Version => 1.7 (SVN)
2016-01-21 03:41 Ondrej Pokorny Resolution open => fixed
2016-01-21 03:41 Ondrej Pokorny Assigned To Mattias Gaertner => Ondrej Pokorny
2016-01-21 03:41 Ondrej Pokorny Target Version => 1.8
2016-01-21 04:12 Ondrej Pokorny Note Added: 0089141
2016-01-21 09:22 Cyrax Note Added: 0089144
2016-01-21 09:29 Ondrej Pokorny Note Added: 0089145
2016-01-21 12:56 Cyrax Note Added: 0089150
2016-01-21 12:56 Cyrax Status resolved => closed