View Issue Details

IDProjectCategoryView StatusLast Update
0028880LazarusLCLpublic2015-10-20 17:35
ReporterGabor BorosAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux x86_64OSKubuntuOS Version14.04.1
Product Version1.4.5 (SVN)Product Build50075 
Target VersionFixed in Version1.5 (SVN) 
Summary0028880: csNoFocus component style not working properly
DescriptionText selection lost in a TEdit control if click on a TCustomControl descendant which have csNoFocus component style
Steps To ReproduceStart the attached example, click on the green control. Text selection lost in Edit1(, focus and caret not moved).
TagsNo tags attached.
Fixed in Revision50124,50125
LazTarget1.4.6
WidgetsetQT
Attached Files

Activities

Gabor Boros

2015-10-19 16:54

reporter  

csNoFocus.tar.gz (1,551 bytes)

Zeljan Rikalo

2015-10-19 17:13

developer   ~0086708

Cannot reproduce here: Fedora 19 64bit, Qt-4.8.6. I'll leave it open for some time until I test on Mac, Win32 and other distros except Kubuntu 14.04

Gabor Boros

2015-10-19 19:32

reporter   ~0086716

I can reproduce with CentOS 7 live (CentOS-7-x86_64-LiveKDE-1509-01.iso) and
Kubuntu 15.04 live (kubuntu-15.04-desktop-amd64.iso).

I focused to my green control but click on the form give same result (Edit1 lose text selection) for me.

Zeljan Rikalo

2015-10-20 09:28

developer   ~0086726

Please test and close if ok.

Gabor Boros

2015-10-20 10:14

reporter   ~0086729

Worse than the original. Create a new project, drop a TEdit to Form1, start.
Before fix if click on the form text selection cleared in Edit1 but caret not moved. After fix Edit1 refocused I think. You see if click into Edit1 and click to Form1 after or select some characters with mouse in Edit1 and click to Form1.

Meanwhile I examined other controls in before fix state(with fixes_1_4). So, TEdit have the problem, TMemo not, TComboBox have. Strange because TMemo is TCustomEdit descendant an TComboBox not.

Zeljan Rikalo

2015-10-20 13:19

developer   ~0086737

Probably related to AutoSelect property.

Zeljan Rikalo

2015-10-20 14:39

developer   ~0086738

Indeed. I'll fix it. It's not related to AutoSelect property.

Gabor Boros

2015-10-20 14:41

reporter   ~0086739

I see no difference between AutoSelect True and False and not found where text selection cleared. SelStart, SelLenght, SetCaretPos not fired if click outside of Edit1.

Zeljan Rikalo

2015-10-20 15:10

developer   ~0086740

Please close if ok. Note: Must test behaviour of qtlcl on windows.

Gabor Boros

2015-10-20 17:35

reporter   ~0086751

Tested and fix confirmed with trunk 50125 and Kubuntu 14.04.1. I not use Qt on Windows but tested with Win32 and Qt 4.8.5 too.

Issue History

Date Modified Username Field Change
2015-10-19 16:54 Gabor Boros New Issue
2015-10-19 16:54 Gabor Boros File Added: csNoFocus.tar.gz
2015-10-19 17:08 Zeljan Rikalo Assigned To => Zeljan Rikalo
2015-10-19 17:08 Zeljan Rikalo Status new => assigned
2015-10-19 17:13 Zeljan Rikalo LazTarget => -
2015-10-19 17:13 Zeljan Rikalo Note Added: 0086708
2015-10-19 17:13 Zeljan Rikalo Status assigned => feedback
2015-10-19 19:32 Gabor Boros Note Added: 0086716
2015-10-19 19:32 Gabor Boros Status feedback => assigned
2015-10-20 09:28 Zeljan Rikalo Fixed in Revision => 50124
2015-10-20 09:28 Zeljan Rikalo LazTarget - => 1.4.6
2015-10-20 09:28 Zeljan Rikalo Note Added: 0086726
2015-10-20 09:28 Zeljan Rikalo Status assigned => resolved
2015-10-20 09:28 Zeljan Rikalo Fixed in Version => 1.5 (SVN)
2015-10-20 09:28 Zeljan Rikalo Resolution open => fixed
2015-10-20 10:14 Gabor Boros Note Added: 0086729
2015-10-20 12:00 Gabor Boros Status resolved => assigned
2015-10-20 12:00 Gabor Boros Resolution fixed => reopened
2015-10-20 13:19 Zeljan Rikalo Note Added: 0086737
2015-10-20 14:39 Zeljan Rikalo Note Added: 0086738
2015-10-20 14:39 Zeljan Rikalo Status assigned => confirmed
2015-10-20 14:41 Gabor Boros Note Added: 0086739
2015-10-20 15:10 Zeljan Rikalo Fixed in Revision 50124 => 50124,50125
2015-10-20 15:10 Zeljan Rikalo Note Added: 0086740
2015-10-20 15:10 Zeljan Rikalo Status confirmed => resolved
2015-10-20 15:10 Zeljan Rikalo Resolution reopened => fixed
2015-10-20 17:35 Gabor Boros Note Added: 0086751
2015-10-20 17:35 Gabor Boros Status resolved => closed