View Issue Details

IDProjectCategoryView StatusLast Update
0028919LazarusLCLpublic2016-07-04 09:42
ReporterGabor BorosAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.4.5 (SVN)Product Build50149 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0028919: DBGrid OnTitleClick and OnCellClick malfunction
DescriptionOnTitleClick and OnCellClick mixed or OnCellClick fired instead of OnTitleClick etc. See same errors with trunk too and independent from platform(Windows native, Linux-Qt).
Steps To ReproduceStart the attached example. Clicking on the title (FIELD1). Sometimes fired as OnTitleClick sometimes OnCellClick. Clicking on the top left corner(before FIELD1 ) of the grid sometimes fired as OnCellClick more times not fired.

My original problem is a non focusable DBGrid. If add csNoFocus (commented out in the example) every click fired but always as OnCellClick. (And csNoFocus not give the effect which I want from it.)
TagsNo tags attached.
Fixed in Revision52617
LazTarget1.8
Widgetset
Attached Files

Activities

Gabor Boros

2015-10-28 11:13

reporter  

DBGrid_OnClicks.tar.gz (1,737 bytes)

Jesus Reyes

2016-04-26 02:14

developer   ~0092228

I cannot reproduce in current Lazarus trunk, please test and reopen if needed.

Gabor Boros

2016-04-26 09:27

reporter   ~0092231

Works with trunk except one thing. CellClick respond every clicks, but TitleClick respond to every first/second only. If double click on a cell see two Cell in the memo, if double click on the title see only one Title in the memo. CellClick is the correct (respond to every clicks) from my POV.

Jesus Reyes

2016-04-26 23:07

developer   ~0092246

I don't really understand the expression "to every first/second only".

I differ in considering "CellClick" to be OK when "DblClick" is triggered, the second click is not an ordinary click and the user when double clicking something usually does not intend repeat the first action but to trigger some special feature on DblClick. But this is debatable because we don't have a CellDblClick or TitleDblClick (and there are no plans for adding them), will check the code for TitleClick and if is not big problem will make it like CellClick

Jesus Reyes

2016-07-04 08:27

developer   ~0093524

Please test.

Gabor Boros

2016-07-04 09:42

reporter   ~0093526

Works for me with trunk 52617 (Windows, Linux-Qt). Thanks!

Issue History

Date Modified Username Field Change
2015-10-28 11:13 Gabor Boros New Issue
2015-10-28 11:13 Gabor Boros File Added: DBGrid_OnClicks.tar.gz
2015-10-28 11:24 Zeljan Rikalo Assigned To => Jesus Reyes
2015-10-28 11:24 Zeljan Rikalo Status new => assigned
2016-04-26 02:14 Jesus Reyes LazTarget => 1.8
2016-04-26 02:14 Jesus Reyes Note Added: 0092228
2016-04-26 02:14 Jesus Reyes Status assigned => resolved
2016-04-26 02:14 Jesus Reyes Resolution open => no change required
2016-04-26 02:14 Jesus Reyes Target Version => 1.8
2016-04-26 09:27 Gabor Boros Note Added: 0092231
2016-04-26 09:27 Gabor Boros Status resolved => assigned
2016-04-26 09:27 Gabor Boros Resolution no change required => reopened
2016-04-26 23:07 Jesus Reyes Note Added: 0092246
2016-07-04 08:27 Jesus Reyes Fixed in Revision => 52617
2016-07-04 08:27 Jesus Reyes Note Added: 0093524
2016-07-04 08:27 Jesus Reyes Status assigned => resolved
2016-07-04 08:27 Jesus Reyes Fixed in Version => 1.7 (SVN)
2016-07-04 08:27 Jesus Reyes Resolution reopened => fixed
2016-07-04 09:42 Gabor Boros Note Added: 0093526
2016-07-04 09:42 Gabor Boros Status resolved => closed