View Issue Details

IDProjectCategoryView StatusLast Update
0029013FPCCompilerpublic2015-11-21 20:50
ReporterCyraxAssigned ToMarco van de Voort 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformWindows OSServer 2008 R2OS Version6.1.7601 (SP1)
Product Version3.1.1Product Buildr32342 
Target VersionFixed in Version 
Summary0029013: Can't build Win64 version of compiler.
DescriptionSee summary and Additional Information for more info.

Excerpt from build log:
---
[16.11.2015 08:47:49.788 - __init__:stdout_log:222 - STDOUT - INFO] make.exe -C F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl 'OPT= ' all
[16.11.2015 08:47:49.835 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[6]: Entering directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl'
[16.11.2015 08:47:49.865 - __init__:stdout_log:222 - STDOUT - INFO] make.exe -C win64 all
[16.11.2015 08:47:49.894 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[7]: Entering directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl/win64'
[16.11.2015 08:47:49.930 - __init__:stdout_log:222 - STDOUT - INFO] F:/free_pascal_and_lazarus/fpc/x86_64/binaries/trunk/gmkdir.exe -p F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl/units/x86_64-win64
[16.11.2015 08:47:50.121 - __init__:stdout_log:222 - STDOUT - INFO] F:/free_pascal_and_lazarus/fpc/x86_64/release/binary/fpc_release/bin/x86_64-win64/ppcx64.exe -Ur -Xs -O2 -n -gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vb -XX- -dSYSTEM_DISABLE_INLINE -dTYPINFO_DISABLE_INLINE -dSYSUTILS_DISABLE_INLINE -dSTRINGS_DISABLE_INLINE -dWINDOWS_DISABLE_INLINE -dCTYPES_DISABLE_INLINE -dFPEXTRES_DISABLE_INLINE -dHEAPTRC_DISABLE_INLINE -dMACPAS_DISABLE_INLINE -dFPC_COMPILER_DISABLE_INLINE -dNO_SMART_LINK -Fi../inc -Fi../x86_64 -FE. -FUF:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl/units/x86_64-win64 -dx86_64 -dRELEASE -Us -Sg system.pp -Fi../win
[16.11.2015 08:47:51.190 - __init__:stdout_log:222 - STDOUT - INFO] F:\free_pascal_and_lazarus\fpc\i386\trunk\git_source\rtl\win\syswin.inc(460,27) Warning: Symbol "NoErrMsg" is not portable
[16.11.2015 08:47:51.309 - __init__:stdout_log:222 - STDOUT - INFO] F:\free_pascal_and_lazarus\fpc\i386\trunk\git_source\rtl\win64\system.pp(600,30) Warning: Symbol "startupinfo" is deprecated
[16.11.2015 08:47:51.849 - __init__:stdout_log:222 - STDOUT - INFO] F:\free_pascal_and_lazarus\fpc\i386\trunk\git_source\rtl\win64\system.pp(605,23) Warning: Symbol "startupinfo" is deprecated
[16.11.2015 08:47:52.161 - __init__:stdout_log:222 - STDOUT - INFO] F:/free_pascal_and_lazarus/fpc/x86_64/release/binary/fpc_release/bin/x86_64-win64/ppcx64.exe -Ur -Xs -O2 -n -gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vb -XX- -dSYSTEM_DISABLE_INLINE -dTYPINFO_DISABLE_INLINE -dSYSUTILS_DISABLE_INLINE -dSTRINGS_DISABLE_INLINE -dWINDOWS_DISABLE_INLINE -dCTYPES_DISABLE_INLINE -dFPEXTRES_DISABLE_INLINE -dHEAPTRC_DISABLE_INLINE -dMACPAS_DISABLE_INLINE -dFPC_COMPILER_DISABLE_INLINE -dNO_SMART_LINK -Fi../inc -Fi../x86_64 -FE. -FUF:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl/units/x86_64-win64 -dx86_64 -dRELEASE ../inc/uuchar.pp
[16.11.2015 08:47:52.684 - __init__:stdout_log:222 - STDOUT - INFO] F:/free_pascal_and_lazarus/fpc/x86_64/release/binary/fpc_release/bin/x86_64-win64/ppcx64.exe -Ur -Xs -O2 -n -gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vb -XX- -dSYSTEM_DISABLE_INLINE -dTYPINFO_DISABLE_INLINE -dSYSUTILS_DISABLE_INLINE -dSTRINGS_DISABLE_INLINE -dWINDOWS_DISABLE_INLINE -dCTYPES_DISABLE_INLINE -dFPEXTRES_DISABLE_INLINE -dHEAPTRC_DISABLE_INLINE -dMACPAS_DISABLE_INLINE -dFPC_COMPILER_DISABLE_INLINE -dNO_SMART_LINK -Fi../inc -Fi../x86_64 -FE. -FUF:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl/units/x86_64-win64 -dx86_64 -dRELEASE -I../objpas ../objpas/objpas.pp
[16.11.2015 08:47:52.779 - __init__:stdout_log:222 - STDOUT - INFO] F:/free_pascal_and_lazarus/fpc/x86_64/release/binary/fpc_release/bin/x86_64-win64/ppcx64.exe -Ur -Xs -O2 -n -gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vb -XX- -dSYSTEM_DISABLE_INLINE -dTYPINFO_DISABLE_INLINE -dSYSUTILS_DISABLE_INLINE -dSTRINGS_DISABLE_INLINE -dWINDOWS_DISABLE_INLINE -dCTYPES_DISABLE_INLINE -dFPEXTRES_DISABLE_INLINE -dHEAPTRC_DISABLE_INLINE -dMACPAS_DISABLE_INLINE -dFPC_COMPILER_DISABLE_INLINE -dNO_SMART_LINK -Fi../inc -Fi../x86_64 -FE. -FUF:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl/units/x86_64-win64 -dx86_64 -dRELEASE -Fi../objpas/sysutils -Fi../objpas/classes -Fu../x86_64 -I../win -I../objpas -I../win/wininc -Fu../win/wininc -Fu../win -I../inc -Fu../inc -Fu../objpas buildrtl
[16.11.2015 08:47:52.839 - __init__:stdout_log:222 - STDOUT - INFO] F:\free_pascal_and_lazarus\fpc\i386\trunk\git_source\rtl\inc\fexpand.inc(61,1) Warning: Inlining disabled
[16.11.2015 08:47:52.901 - __init__:stdout_log:222 - STDOUT - INFO] F:\free_pascal_and_lazarus\fpc\i386\trunk\git_source\rtl\inc\heaptrc.pp(992,12) Warning: Comparison is always true due to range of values
[16.11.2015 08:47:52.959 - __init__:stdout_log:222 - STDOUT - INFO] F:\free_pascal_and_lazarus\fpc\i386\trunk\git_source\rtl\inc\typshrdh.inc(49,8) Fatal: Syntax error, ":" expected but "FUNCTION" found
[16.11.2015 08:47:53.016 - __init__:stdout_log:222 - STDOUT - INFO] Fatal: Compilation aborted
[16.11.2015 08:47:53.040 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[7]: *** [buildrtl.ppu] Error 1
[16.11.2015 08:47:53.069 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[7]: Leaving directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl/win64'
[16.11.2015 08:47:53.151 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[6]: *** [win64_all] Error 2
[16.11.2015 08:47:53.224 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[6]: Leaving directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/rtl'
[16.11.2015 08:47:53.253 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[5]: *** [rtl] Error 2
[16.11.2015 08:47:53.293 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[5]: Leaving directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/compiler'
[16.11.2015 08:47:53.325 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[4]: *** [next] Error 2
[16.11.2015 08:47:53.359 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[4]: Leaving directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/compiler'
[16.11.2015 08:47:53.385 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[3]: *** [ppc1.exe] Error 2
[16.11.2015 08:47:53.423 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[3]: Leaving directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/compiler'
[16.11.2015 08:47:53.447 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[2]: *** [cycle] Error 2
[16.11.2015 08:47:53.578 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[2]: Leaving directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source/compiler'
[16.11.2015 08:47:53.657 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[1]: *** [compiler_cycle] Error 2
[16.11.2015 08:47:53.743 - __init__:stdout_log:222 - STDOUT - INFO] make.exe[1]: Leaving directory `F:/free_pascal_and_lazarus/fpc/i386/trunk/git_source'
[16.11.2015 08:47:53.823 - __init__:stdout_log:222 - STDOUT - INFO] make.exe: *** [build-stamp.x86_64-win64] Error 2
---
Additional InformationLazarus revision 50335
FPC revision 32342
 
FPC make commands:
clean
all
install
COMPILER_OPTIONS=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -XX- -dTEST_WIN32_SEH -dSYSTEM_DISABLE_INLINE -dTYPINFO_DISABLE_INLINE -dSYSUTILS_DISABLE_INLINE -dSTRINGS_DISABLE_INLINE -dWINDOWS_DISABLE_INLINE -dCTYPES_DISABLE_INLINE -dFPEXTRES_DISABLE_INLINE -dHEAPTRC_DISABLE_INLINE -dMACPAS_DISABLE_INLINE -dFPC_COMPILER_DISABLE_INLINE -dNO_SMART_LINK
INSTALL_PREFIX=F:\free_pascal_and_lazarus\fpc\i386\trunk\binary\fpc_trunk
UPXPROG=echo
IDE=1
REVSTR=32342
ALLOW_WARNINGS=1
NOWPOCYCLE=1
 
Lazarus make commands:
clean
all
OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -gh -O- -Xs- -Si- -vb -XX- -dTEST_WIN32_SEH -dHEAPTRC_WINDOW -dDBG_WITH_DEBUGGER_DEBUG
UPXPROG=echo
USESVN2REVISIONINC=0
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files
  • windows.pp.patch (346 bytes)
    Index: rtl/win64/windows.pp
    ===================================================================
    --- rtl/win64/windows.pp	(revision 32342)
    +++ rtl/win64/windows.pp	(working copy)
    @@ -22,6 +22,8 @@
     
     { stuff like array of const is used }
     {$mode objfpc}
    +{$modeswitch ADVANCEDRECORDS}
    +{$modeswitch class}
     {$inline on}
     {$calling stdcall}
     
    
    windows.pp.patch (346 bytes)

Relationships

related to 0021041 resolvedMarco van de Voort Extend the TRect type with some useful methods 

Activities

Cyrax

2015-11-16 08:23

reporter   ~0087309

Maybe related to bug report http://bugs.freepascal.org/view.php?id=21041 ?

Although 32-bit version of compiler builds successfully.

Cyrax

2015-11-16 10:48

reporter  

windows.pp.patch (346 bytes)
Index: rtl/win64/windows.pp
===================================================================
--- rtl/win64/windows.pp	(revision 32342)
+++ rtl/win64/windows.pp	(working copy)
@@ -22,6 +22,8 @@
 
 { stuff like array of const is used }
 {$mode objfpc}
+{$modeswitch ADVANCEDRECORDS}
+{$modeswitch class}
 {$inline on}
 {$calling stdcall}
 
windows.pp.patch (346 bytes)

Cyrax

2015-11-16 10:48

reporter   ~0087313

Attached patch which fixes this bug.

Marco van de Voort

2015-11-16 21:21

manager   ~0087331

Already fixed during the day after a report on core. Also for wince.

Issue History

Date Modified Username Field Change
2015-11-16 08:22 Cyrax New Issue
2015-11-16 08:23 Cyrax Note Added: 0087309
2015-11-16 08:29 Jonas Maebe Summary Can't build 64-bit version of compiler. => Can't build Win64 version of compiler.
2015-11-16 08:32 Jonas Maebe Relationship added related to 0021041
2015-11-16 10:48 Cyrax File Added: windows.pp.patch
2015-11-16 10:48 Cyrax Note Added: 0087313
2015-11-16 21:21 Marco van de Voort Note Added: 0087331
2015-11-16 21:21 Marco van de Voort Status new => resolved
2015-11-16 21:21 Marco van de Voort Resolution open => no change required
2015-11-16 21:21 Marco van de Voort Assigned To => Marco van de Voort
2015-11-21 20:50 Cyrax Status resolved => closed