View Issue Details

IDProjectCategoryView StatusLast Update
0029017FPCCompilerpublic2016-01-25 14:29
ReporterMarius MaximusAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platform64bitOSDebianOS Version8
Product Version3.1.1Product Build 
Target VersionFixed in Version 
Summary0029017: Can't build FPC after revision 32335
DescriptionError message:

/home/l1/t11/fpcbootstrap/x86_64-linux-ppcx64 -Ur -Ur -Xs -O2 -n -Fi../inc -Fi../x86_64 -Fi../unix -Fix86_64 -FE. -FU/home/l1/t11/fpc/rtl/units/x86_64-linux -Cg -g -gl -O1 -dx86_64 -dRELEASE ../objpas/types.pp
typshrdh.inc(54,23) Error: It is not possible to overload this operator. Related overloadable operators (if any) are:
typshrdh.inc(54,24) Error: It is not possible to overload this operator. Related overloadable operators (if any) are:
typshrdh.inc(54,24) Fatal: Syntax error, ":" expected but ">" found
Fatal: Compilation aborted

Steps To Reproduce./fpcup_linux_x64 \
    --installdir=/home/l1/t11 \
    --noconfirm --verbose \
    --fpcURL=trunk --lazURL=trunk \
    --fpcopt="-g -gl -O1" --lazopt="-g -gl -O1" \
    --logfilename=fpc64.log \
    --lazlinkname=LAZ_64 --include=zeos,bgracontrols

TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Jonas Maebe

2015-11-16 13:21

manager   ~0087316

What is the version number of your bootstrap compiler?

Marius Maximus

2015-11-16 21:43

reporter   ~0087337

./x86_64-linux-ppcx64 -v
Free Pascal Compiler version 2.6.2 [2013/02/16] for x86_64
Copyright (c) 1993-2012 by Florian Klaempfl and others

Marco van de Voort

2015-11-16 21:53

manager   ~0087340

The only supported bootstrap compiler is the previous release, which is currently 2.6.4

Jonas Maebe

2015-11-16 23:09

manager   ~0087342

Please remove any make options you may have added to disable version checks, because normally the makefile will abort if you use an unsupported version to bootstrap.

Issue History

Date Modified Username Field Change
2015-11-16 13:09 Marius Maximus New Issue
2015-11-16 13:21 Jonas Maebe Note Added: 0087316
2015-11-16 13:21 Jonas Maebe Status new => feedback
2015-11-16 21:43 Marius Maximus Note Added: 0087337
2015-11-16 21:43 Marius Maximus Status feedback => new
2015-11-16 21:53 Marco van de Voort Note Added: 0087340
2015-11-16 23:09 Jonas Maebe Note Added: 0087342
2015-11-16 23:09 Jonas Maebe Status new => resolved
2015-11-16 23:09 Jonas Maebe Resolution open => no change required
2015-11-16 23:09 Jonas Maebe Assigned To => Jonas Maebe
2016-01-25 14:29 Marius Maximus Status resolved => closed