View Issue Details

IDProjectCategoryView StatusLast Update
0029184LazarusIDEpublic2016-01-16 23:56
ReporterOivind ToienAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform86OSWindowsOS Version7 64-bit
Product Version1.5 (SVN)Product Build50707 (1.6 RC1, not listed ) 
Target Version1.6Fixed in Version1.7 (SVN) 
Summary0029184: Desktop with anchor docking on secondary display jumps to primary display on next launch.
DescriptionWith 1.6 RC1 (50707) and from 1.5 trunk after bug 0028704 was "resolved":
The new desktop configuration (controlled under Manage desktops dialog) does not remember coordinates on a secondary display with anchor docking active (not tested undocked). Once Lazarus is opened again it jumps to the primary display and shape of windows change, apparently scaled relative to the edges of the screen. It is very awkward to then move it back to the secondary display again if the Scale on resize option is off (necessary to avoid the bug where the messages window keeps growing every time Lazarus is started), as the window has expanded. If for instance code explorer is kept at the right edge, it will be out of the window with the screens specified below.

This works fine in the 1.4.3 fixes branch before the new desktop configuration was introduced in trunk 1.5; Lazarus stayed on the secondary display with everything at the last used coordinates.

This is tested under Win 7 64 bit system, 32-bit Lazarus, primary display on notebook computer is 1920x 1080, secondary display 1600x1200, extended desktop mode.
Steps To ReproduceBuild Lazarus with anchor docking installed. Move IDE to a secondary display which is on the expanded desktop, but has different dimensions from the primary display (I do not know if the latter matters). Dock object inspector etc. to your liking. Exit Lazarus. Relaunch Lazarus. It will now have jumped to the primary display as described above.
Additional Information
Apparently the new desktop configuration needs some more work with respect to how it saves window positions.
TagsAnchorDocking
Fixed in Revision50784
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0028704 resolvedJuha Manninen Anchordocking design does not save settings 

Activities

Ondrej Pokorny

2015-12-14 10:08

developer   ~0087941

Please test and close if OK.

Oivind Toien

2015-12-15 14:25

reporter   ~0087972

Unfortunately I have problems with updating to 1.7 trunc version to test it. Is there a chance that this fix will end up in 1.6 RC2 ?

Ondrej Pokorny

2015-12-15 16:16

developer   ~0087973

I first wanted to wait until you confirm that the issue is solved but then decided to merge r50784 to 1.6 as it fixed a clear bug. So yes, this fix will be in 1.6 RC2. (See "Target Version 1.6".)

Oivind Toien

2016-01-16 08:06

reporter   ~0088940

Last edited: 2016-01-16 08:14

View 2 revisions

Yes, it works in 1.6 RC2, thanks!

Somewhat off the bug topic, but it seems the scale on resize bug where the message window keep growing is gone too, nice!

Ondrej Pokorny

2016-01-16 08:52

developer   ~0088941

Last edited: 2016-01-16 08:52

View 2 revisions

>> Somewhat off the bug topic, but it seems the scale on resize bug where the message window keep growing is gone too, nice!

I have solved that one as well.

---
Please close this report.

Issue History

Date Modified Username Field Change
2015-12-14 03:06 Oivind Toien New Issue
2015-12-14 09:38 Ondrej Pokorny Relationship added related to 0028704
2015-12-14 09:41 Ondrej Pokorny LazTarget => -
2015-12-14 09:41 Ondrej Pokorny Assigned To => Ondrej Pokorny
2015-12-14 09:41 Ondrej Pokorny Status new => confirmed
2015-12-14 09:41 Ondrej Pokorny Status confirmed => assigned
2015-12-14 10:08 Ondrej Pokorny Fixed in Revision => 50784
2015-12-14 10:08 Ondrej Pokorny Note Added: 0087941
2015-12-14 10:08 Ondrej Pokorny Status assigned => resolved
2015-12-14 10:08 Ondrej Pokorny Fixed in Version => 1.7 (SVN)
2015-12-14 10:08 Ondrej Pokorny Resolution open => fixed
2015-12-14 10:08 Ondrej Pokorny Target Version => 1.6
2015-12-15 14:25 Oivind Toien Note Added: 0087972
2015-12-15 16:16 Ondrej Pokorny Note Added: 0087973
2016-01-16 08:06 Oivind Toien Note Added: 0088940
2016-01-16 08:14 Oivind Toien Note Edited: 0088940 View Revisions
2016-01-16 08:52 Ondrej Pokorny Note Added: 0088941
2016-01-16 08:52 Ondrej Pokorny Note Edited: 0088941 View Revisions
2016-01-16 23:56 Anthony Walter Tag Attached: AnchorDocking