View Issue Details

IDProjectCategoryView StatusLast Update
0029201LazarusIDEpublic2016-01-03 17:17
ReporterJuha ManninenAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSXubuntuOS Version15.10
Product Version1.7 (SVN)Product Buildr50644 
Target Version1.6Fixed in Version1.7 (SVN) 
Summary0029201: Sparta docked form editor was broken by r50644
DescriptionThe IDE now dies when sparta_DockedFormEditor package is installed.
When opening a form it throws access violations and other errors. I copied some output to Additional Information, including a gdb backtrace.
AnchorDocking was not installed during my tests.

I bisected the quilty revision and it is r50644:
 "IDE: load lfm: when class not found, show ignore only when possible"

This revision was also merged to 1.6.
Additional InformationTLazarusManager.Run starting /home/juha/SW/lazarus_gitsvn/lazarus ...
SetPrimaryConfigPath NewValue="/home/juha/.lazarus" -> "/home/juha/.lazarus"
Hint: (lazarus) [TMainIDE.ParseCmdLineOptions] PrimaryConfigPath="/home/juha/.lazarus/"
Hint: (lazarus) [TMainIDE.ParseCmdLineOptions] SecondaryConfigPath="/etc/lazarus"
Hint: (lazarus) [TBuildManager.SetBuildTarget] Old=x86_64-linux-qt New=x86_64-linux-qt FPC=True LCL=False
TLazSourceFileManager.FindComponentClass Failed finding reference of TBasePackageEditor in /home/juha/SW/lazarus_gitsvn/packager/packageeditor.pas
TLazSourceFileManager.FindComponentClass.TryRegisteredClasses found: TFakeForm
TLazSourceFileManager.LoadComponentDependencyHidden /home/juha/SW/lazarus_gitsvn/packager/packageeditor.pas AComponentClassName=TBasePackageEditor AComponentClass=nil AncestorClass=TFakeForm LFMFilename=
[TJITForms.DoCreateJITComponent] Error while creating instance: NewComponentName="" NewClassName="TPackageEditorForm" NewUnitName="PackageEditor"
[TJITForms.DoCreateJITComponent] Error Error: Object reference is Nil
  Stack trace:
  $000000000143936C line 614 of source/sparta_mainide.pas
  $0000000001439295 line 608 of source/sparta_mainide.pas
  $000000000143A579 line 893 of source/sparta_mainide.pas
  $00000000004884EE line 1066 of include/screen.inc
  $00000000004870F2 line 724 of include/screen.inc
  $0000000000480217 line 2025 of include/customform.inc
  $000000000047FB57 line 1964 of include/customform.inc
  $00000000004836B2 line 3067 of include/customform.inc
  $0000000000A58C83 line 1061 of ../designer/jitforms.pp
  $0000000000A57E5E line 929 of ../designer/jitforms.pp
  $0000000000A86CDB line 1496 of customformeditor.pp
  $0000000000D57CF0 line 5965 of sourcefilemanager.pas
  $0000000000D56CAF line 5766 of sourcefilemanager.pas
  $0000000000D3C02D line 866 of sourcefilemanager.pas
  $0000000000D3E635 line 1355 of sourcefilemanager.pas
  $0000000000D3A416 line 395 of sourcefilemanager.pas
  $0000000000D4A3E3 line 3645 of sourcefilemanager.pas
TCustomFormEditor.JITListException List.CurReadStreamClass=nil TUnitInfo
[TJITForms.DoCreateJITComponent] Error while destroying instance: NewComponentName="" NewClassName="TPackageEditorForm" NewUnitName="PackageEditor" Error: Access violation
  Stack trace:
  $000000000043596D
  $0000000000A57E5E line 929 of ../designer/jitforms.pp
  $0000000000A86CDB line 1496 of customformeditor.pp
  $0000000000D57CF0 line 5965 of sourcefilemanager.pas
  $0000000000D56CAF line 5766 of sourcefilemanager.pas
  $0000000000D3C02D line 866 of sourcefilemanager.pas
  $0000000000D3E635 line 1355 of sourcefilemanager.pas
  $0000000000D3A416 line 395 of sourcefilemanager.pas
  $0000000000D4A3E3 line 3645 of sourcefilemanager.pas
  $00000000004C6324 line 6220 of main.pp
  $00000000004AE414 line 2270 of main.pp
  $00000000004AA533 line 1583 of main.pp
  $00000000004235BF line 133 of lazarus.pp
TCustomFormEditor.JITListException List.CurReadStreamClass=nil TUnitInfo
ERROR: streaming failed lfm="/home/juha/SW/lazarus_gitsvn/packager/packageeditor.lfm"
TDefinePropertiesReader.AddPropertyName Name="left"
TDefinePropertiesReader.AddPropertyName Name="top"
TCustomFormEditor.FindDefineProperty Class=TPopupMenu DefineProps="left
top
"
TFileOpener.OpenResource LoadLFM failed
TFileOpener.OpenEditorFile failed OpenResource: /home/juha/SW/lazarus_gitsvn/packager/packageeditor.pas

--- Backtrace ---

Program received signal SIGSEGV, Segmentation fault.
0x000000000043596d in SYSTEM$_$TOBJECT_$__$$_FREE ()
(gdb)
(gdb) bt
#0 0x000000000043596d in SYSTEM$_$TOBJECT_$__$$_FREE ()
0000001 0x00007fffffffca50 in ?? ()
0000002 0x0000000000a5900e in DOCREATEJITCOMPONENT (this=0x7fffdc787740, NEWCOMPONENTNAME=..., NEWCLASSNAME=..., NEWUNITNAME=..., ANCESTORCLASS=0x1a54780, VISIBLE=true,
    DISABLEAUTOSIZE=true) at ../designer/jitforms.pp:1088
0000003 0x0000000000a57e5e in ADDJITCOMPONENTFROMSTREAM (this=0x7fffdc787740, BINSTREAM=0x7fffd134d080, UNITRESOURCEFILEFORMAT=0x1cbf7c8, ANCESTORCLASS=0x1a54780,
    NEWUNITNAME=..., INTERACTIVE=true, VISIBLE=true, DISABLEAUTOSIZE=true, CONTEXTOBJ=0x7fffd0ff1e90) at ../designer/jitforms.pp:929
0000004 0x0000000000a86cdb in CREATERAWCOMPONENTFROMSTREAM (this=0x7fffdc6e2920, BINSTREAM=0x7fffd134d080, UNITRESOURCEFILEFORMAT=0x1cbf7c8, ANCESTORTYPE=0x1a54780,
    NEWUNITNAME=..., INTERACTIVE=true, VISIBLE=true, DISABLEAUTOSIZE=true, CONTEXTOBJ=0x7fffd0ff1e90) at customformeditor.pp:1496
0000005 0x0000000000d57cf0 in LOADLFM (this=0x7fffd8018600, ANUNITINFO=0x7fffd0ff1e90, LFMBUF=0x7fffd16e9400, OPENFLAGS=..., CLOSEFLAGS=...) at sourcefilemanager.pas:5965
0000006 0x0000000000d56caf in LOADLFM (this=0x7fffd8018600, ANUNITINFO=0x7fffd0ff1e90, OPENFLAGS=..., CLOSEFLAGS=...) at sourcefilemanager.pas:5766
0000007 0x0000000000d3c02d in OPENRESOURCE (this=0x7fffdd0a1bc0) at sourcefilemanager.pas:866
0000008 0x0000000000d3e635 in OPENEDITORFILE (this=0x7fffdd0a1bc0, APAGEINDEX=-1, AWINDOWINDEX=0, AEDITORINFO=0x7fffd0f46080, AFLAGS=...) at sourcefilemanager.pas:1355
0000009 0x0000000000d3a416 in OPENEDITORFILE (AFILENAME=0x7fffd15cd2d8 "/home/juha/SW/lazarus_gitsvn/packager/packageeditor.pas", PAGEINDEX=-1, WINDOWINDEX=0,
    AEDITORINFO=0x7fffd0f46080, FLAGS=..., USEWINDOWID=true) at sourcefilemanager.pas:395
0000010 0x0000000000d4a3e3 in INITOPENEDPROJECTFILE (this=0x7fffd8018600, AFILENAME=0x7fffd1544258 "/home/juha/SW/lazarus_gitsvn/ide/lazarus.lpi", FLAGS=...)
    at sourcefilemanager.pas:3645
0000011 0x00000000004c6324 in DOOPENPROJECTFILE (this=0x7fffde713990, AFILENAME=0x7fffd1544258 "/home/juha/SW/lazarus_gitsvn/ide/lazarus.lpi", FLAGS=...) at main.pp:6220
0000012 0x00000000004ae414 in SETUPSTARTPROJECT (this=0x7fffde713990) at main.pp:2270
0000013 0x00000000004aa533 in STARTIDE (this=0x7fffde713990) at main.pp:1583
0000014 0x00000000004235bf in main () at lazarus.pp:133
TagsNo tags attached.
Fixed in Revision51161
LazTarget-
Widgetset
Attached Files

Activities

Ondrej Pokorny

2016-01-03 15:44

developer   ~0088546

Please test.

Juha Manninen

2016-01-03 17:17

developer   ~0088560

Strangely I could not reproduce this any more for some time.

Issue History

Date Modified Username Field Change
2015-12-16 22:57 Juha Manninen New Issue
2015-12-16 22:57 Juha Manninen Status new => assigned
2015-12-16 22:57 Juha Manninen Assigned To => Mattias Gaertner
2015-12-16 23:13 Juha Manninen Description Updated View Revisions
2015-12-17 12:29 Juha Manninen Description Updated View Revisions
2016-01-03 15:43 Ondrej Pokorny Assigned To Mattias Gaertner => Ondrej Pokorny
2016-01-03 15:44 Ondrej Pokorny Fixed in Revision => 51161
2016-01-03 15:44 Ondrej Pokorny Note Added: 0088546
2016-01-03 15:44 Ondrej Pokorny Status assigned => resolved
2016-01-03 15:44 Ondrej Pokorny Fixed in Version => 1.7 (SVN)
2016-01-03 15:44 Ondrej Pokorny Resolution open => fixed
2016-01-03 17:17 Juha Manninen Note Added: 0088560
2016-01-03 17:17 Juha Manninen Status resolved => closed