View Issue Details

IDProjectCategoryView StatusLast Update
0029260LazarusLCLpublic2020-04-01 10:40
ReporterOndrej Pokorny Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
PlatformLinuxOSKubuntu Linux 
Product Version1.7 (SVN) 
Summary0029260: Parented modal window doesn't visually disable non-parented non-modal windows
DescriptionIf you open a modal window from a parented non-modal window, it does not visually disable non-modal windows with a different PopupParent.
Steps To ReproduceSee the attached project. Click on Button1 and then click on a button of one of the new dialogs (Form2, Dlg).
Additional InformationIt doesn't work both on Gtk2 and Qt under Linux.
Qt on Windows behaves correctly.

It is only a small visual issue. All dialogs are unavailable for mouse clicks and keyboard input.

It is not a regression from 0029253 or other issues.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2, QT
Attached Files

Activities

Ondrej Pokorny

2015-12-27 09:17

developer  

test-with-modal.zip (2,990 bytes)

Ondrej Pokorny

2015-12-27 09:18

developer  

test-with-modal.png (16,478 bytes)   
test-with-modal.png (16,478 bytes)   

Zeljan Rikalo

2015-12-27 09:34

developer   ~0088293

That's only under compositing window manager. Under normal WM everything looks ok, you cannot activate any window below modal window.

Zeljan Rikalo

2015-12-27 09:38

developer   ~0088294

What if you set PopupMode=pmNone for form3 (modal form) from your example ? What happens then with other windows ?

Ondrej Pokorny

2015-12-27 09:48

developer   ~0088298

>> you cannot activate any window below modal window

Yes, I confirm this. This issue is only a visual one. The dialog appears as if it was available (WRONG) but it is unavailable (CORRECT).
As you can see from the screenshot, only 2 of 3 non-modal windows are dimmed. All of them are unavailable, though.

>> What if you set PopupMode=pmNone for form3 (modal form) from your example ? What happens then with other windows ?

It's the same scenario.

Zeljan Rikalo

2015-12-27 10:17

developer   ~0088300

We'll see then. Probably I'll resolve this as unfixable, but first I'll try to find some solution.

Zeljan Rikalo

2020-04-01 10:40

developer   ~0121821

This is usually window manager (compositing one) problem since LCL correctly passes modal params to windows. Not fixable.

Issue History

Date Modified Username Field Change
2015-12-27 09:17 Ondrej Pokorny New Issue
2015-12-27 09:17 Ondrej Pokorny File Added: test-with-modal.zip
2015-12-27 09:18 Ondrej Pokorny File Added: test-with-modal.png
2015-12-27 09:33 Zeljan Rikalo Assigned To => Zeljan Rikalo
2015-12-27 09:33 Zeljan Rikalo Status new => assigned
2015-12-27 09:34 Zeljan Rikalo Note Added: 0088293
2015-12-27 09:34 Zeljan Rikalo Status assigned => feedback
2015-12-27 09:38 Zeljan Rikalo Note Added: 0088294
2015-12-27 09:48 Ondrej Pokorny Note Added: 0088298
2015-12-27 09:48 Ondrej Pokorny Status feedback => assigned
2015-12-27 10:17 Zeljan Rikalo Note Added: 0088300
2020-04-01 10:40 Zeljan Rikalo Status assigned => resolved
2020-04-01 10:40 Zeljan Rikalo Resolution open => not fixable
2020-04-01 10:40 Zeljan Rikalo Widgetset GTK 2, QT => GTK 2, QT
2020-04-01 10:40 Zeljan Rikalo Note Added: 0121821