View Issue Details

IDProjectCategoryView StatusLast Update
0029310LazarusLCLpublic2016-12-18 10:50
ReporterOndrej PokornyAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.7 (SVN)Product Buildtrunk 
Target Version1.6Fixed in Version1.7 (SVN) 
Summary0029310: When resizing a form, wrong ClientHeight is retrieved (increased by MainMenu height)
DescriptionIf you have a MainMenu on the form, the ClientHeight is temporarily wrongly increased by MainMenu height.
Steps To ReproduceSee the attached example project. Try to resize the form's width. You'll see that Resizing procedures are called with 2 different ClientHeight values.

Wrong value: wcfClientRectNeedsUpdate is in FWinControlFlags.
Correct value: wcfClientRectNeedsUpdate isn't in FWinControlFlags.
Additional InformationTested on win32.
TagsNo tags attached.
Fixed in Revision51115
LazTarget1.6
Widgetset
Attached Files

Relationships

parent of 0029308 closedOndrej Pokorny flick on IDE window resize if anchordockingdsgn installed 
related to 0029445 closedOndrej Pokorny Empty window after minimize and restore 
related to 0030826 closedMichl TWinControl.WMSize loop detected 

Activities

Ondrej Pokorny

2016-01-02 11:26

reporter  

ClientRect-Resize.zip (2,173 bytes)

Ondrej Pokorny

2016-01-02 12:52

reporter   ~0088526

Info: Resizing call is not needed in TCustomForm.WMSize because it is done in TScrollingWinControl.WMSize. The NewState must always be supplied in Message.SizeType attribute.

Issue History

Date Modified Username Field Change
2016-01-02 11:26 Ondrej Pokorny New Issue
2016-01-02 11:26 Ondrej Pokorny File Added: ClientRect-Resize.zip
2016-01-02 11:30 Ondrej Pokorny Relationship added parent of 0029308
2016-01-02 11:34 Mattias Gaertner Relationship added related to 0018298
2016-01-02 11:34 Mattias Gaertner Relationship deleted related to 0018298
2016-01-02 11:49 Ondrej Pokorny Assigned To => Ondrej Pokorny
2016-01-02 11:49 Ondrej Pokorny Status new => assigned
2016-01-02 12:52 Ondrej Pokorny Fixed in Revision => 51115
2016-01-02 12:52 Ondrej Pokorny LazTarget - => 1.6
2016-01-02 12:52 Ondrej Pokorny Note Added: 0088526
2016-01-02 12:52 Ondrej Pokorny Status assigned => resolved
2016-01-02 12:52 Ondrej Pokorny Fixed in Version => 1.7 (SVN)
2016-01-02 12:52 Ondrej Pokorny Resolution open => fixed
2016-01-02 12:52 Ondrej Pokorny Target Version => 1.6
2016-01-10 11:26 Ondrej Pokorny Status resolved => closed
2016-01-18 22:15 Ondrej Pokorny Relationship added related to 0029445
2016-12-18 10:50 Michl Relationship added related to 0030826