View Issue Details

IDProjectCategoryView StatusLast Update
0029418LazarusLCLpublic2017-02-04 14:05
ReportermelwinekAssigned ToMichl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version1.4.4Product Build 
Target Version1.6.2Fixed in Version1.6.2 
Summary0029418: Combobox, DBLookupCombobox does not search correctly.
DescriptionIm my test form is only Combobox and Button.
When Program start, Value in Combobox is not correct, after button click is correct.

In attachment is two screenshoots (before and after button click) and source.

My code:

  object Button1: TButton
    Left = 96
    Height = 25
    Top = 80
    Width = 75
    Caption = 'Button1'
    OnClick = Button1Click
    TabOrder = 0
  end
  object ComboBox1: TComboBox
    Left = 80
    Height = 23
    Top = 41
    Width = 100
    AutoComplete = True
    AutoCompleteText = [cbactEnabled, cbactEndOfLineComplete, cbactSearchAscending]
    ItemHeight = 15
    Items.Strings = (
      'AAB'
      'AĄB'
      'ABB'
    )
    Sorted = True
    Style = csDropDownList
    TabOrder = 1
  end

procedure TForm1.FormCreate(Sender: TObject);
begin
  ComboBox1.ItemIndex:=ComboBox1.Items.IndexOf('ABB');
end;

procedure TForm1.Button1Click(Sender: TObject);
begin
  ComboBox1.ItemIndex:=ComboBox1.Items.IndexOf('ABB');
end;
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

melwinek

2016-01-16 14:45

reporter  

TEST.ZIP (141,744 bytes)

Michl

2017-02-04 14:05

developer   ~0097963

The problem is visible in Lazarus 1.6.0

The problem isn't visible in:
Lazarus 1.6.2
Lazarus 1.6.3 fixes
Lazarus 1.7 trunk

Seems to be fixed in meantime.

Issue History

Date Modified Username Field Change
2016-01-16 14:45 melwinek New Issue
2016-01-16 14:45 melwinek File Added: TEST.ZIP
2017-02-04 14:05 Michl LazTarget => -
2017-02-04 14:05 Michl Note Added: 0097963
2017-02-04 14:05 Michl Status new => resolved
2017-02-04 14:05 Michl Fixed in Version => 1.6.2
2017-02-04 14:05 Michl Resolution open => fixed
2017-02-04 14:05 Michl Assigned To => Michl
2017-02-04 14:05 Michl Target Version => 1.6.2