View Issue Details

IDProjectCategoryView StatusLast Update
0029530LazarusIDEpublic2017-12-12 18:20
ReporterBuckwheat1Assigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct BuildLazarus svn revision: 51246 
Target Version1.6Fixed in Version1.7 (SVN) 
Summary0029530: idecommands crash, when closing options dlg [Lazarus stops responding and "dies" when Brackets highlight]
DescriptionLazarus stops responding and "dies" when Brackets highlight color is set forth time in a row.
Steps To Reproduce1. Tools->Options->Editor->Display->Colors->Brackets highlight->OK.
2. Tools->Options->Editor->Display->Colors->Brackets highlight->OK.
3. Tools->Options->Editor->Display->Colors->Brackets highlight->OK.
4. Tools->Options ... Lazarus stops responding and "dies".
Additional InformationLazarus version: 1.6RC2
Lazarus svn revision: 51246
Lazarus build date: 2016/01/10
Lazarus was compiled for i386-win32
Lazarus was compiled with fpc 3.0.0

Global IDE options:
Primary config directory=C:\Users\Joe\AppData\Local\lazarus-1.6RC2-fpc-3.0.0-win32\
Secondary config directory=C:\lazarus-1.6RC2-fpc-3.0.0-win32
LazarusDirectory=
Real LazarusDirectory=C:\lazarus-1.6RC2-fpc-3.0.0-win32\
Default CompilerFilename=C:\lazarus-1.6RC2-fpc-3.0.0-win32\fpc\3.0.0\bin\i386-win32\fpc.exe
Real Default CompilerFilename=C:\lazarus-1.6RC2-fpc-3.0.0-win32\fpc\3.0.0\bin\i386-win32\fpc.exe
Project CompilerFilename=$(CompPath)
Real Project CompilerFilename=C:\lazarus-1.6RC2-fpc-3.0.0-win32\fpc\3.0.0\bin\i386-win32\fpc.exe
CompilerMessagesFilename=
Real CompilerMessagesFilename=C:\lazarus-1.6RC2-fpc-3.0.0-win32\components\codetools\fpc.errore.msg
FPC source directory=$(LazarusDir)fpc\$(FPCVer)\source
Real FPC source directory=C:\lazarus-1.6RC2-fpc-3.0.0-win32\fpc\3.0.0\source\
Test directory=C:\Users\Joe\AppData\Local\Temp\
Real Test directory=C:\Users\Joe\AppData\Local\Temp\

Working directory=C:\lazarus-1.6RC2-fpc-3.0.0-win32
Application.ExeName=C:\lazarus-1.6RC2-fpc-3.0.0-win32\lazarus.exe

Parameters:
C:\lazarus-1.6RC2-fpc-3.0.0-win32\lazarus.exe

Environment variables:
=::=::\
=::=::\
ALLUSERSPROFILE=C:\ProgramData
APPDATA=C:\Users\Joe\AppData\Roaming
CommonProgramFiles=C:\Program Files (x86)\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
COMPUTERNAME=TOSHIBA
ComSpec=C:\WINDOWS\system32\cmd.exe
FPS_BROWSER_APP_PROFILE_STRING=Internet Explorer
FPS_BROWSER_USER_PROFILE_STRING=Default
FP_NO_HOST_CHECK=NO
GNUPLOT_LIB=C:\Program Files\gnuplot\demo
HOMEDRIVE=C:
HOMEPATH=\Users\Joe
LOCALAPPDATA=C:\Users\Joe\AppData\Local
LOGONSERVER=\\TOSHIBA
NUMBER_OF_PROCESSORS=4
OS=Windows_NT
Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\KDiff3;C:\Program Files (x86)\GnuWin32\bin\;C:\Program Files (x86)\Aspell\bin\;C:\tidy5-4.9.35-win64\bin\;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\ImageMagick-6.9.1-Q16;C:\Python27\;C:\Python27\Scripts;C:\fossil-w32-1.34\;C:\Tcl\bin;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\jEdit;C:\Program Files\TortoiseHg\;C:\sfk
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC;.tcl
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_ARCHITEW6432=AMD64
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 37 Stepping 2, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=2502
ProgramData=C:\ProgramData
ProgramFiles=C:\Program Files (x86)
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
PSModulePath=C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\
PUBLIC=C:\Users\Public
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\WINDOWS
TEMP=C:\Users\Joe\AppData\Local\Temp
TMP=C:\Users\Joe\AppData\Local\Temp
UD_INSTALL_DIR=C:\windows\UltraDefrag
USERDOMAIN=TOSHIBA
USERDOMAIN_ROAMINGPROFILE=TOSHIBA
USERNAME=Joe
USERPROFILE=C:\Users\Joe
windir=C:\WINDOWS
==============================================================================
Host Name: TOSHIBA
OS Name: Microsoft Windows 10 Home
OS Version: 10.0.10586 N/A Build 10586
OS Manufacturer: Microsoft Corporation
OS Configuration: Standalone Workstation
OS Build Type: Multiprocessor Free
Registered Owner: Joe
Registered Organization: Toshiba
Product ID: 00326-10000-00000-AA242
Original Install Date: 2015-11-30, 13:49:57
System Boot Time: 2016-01-21, 08:40:22
System Manufacturer: TOSHIBA
System Model: Satellite L670
System Type: x64-based PC
Processor(s): 1 Processor(s) Installed.
                           [01]: Intel64 Family 6 Model 37 Stepping 2 GenuineIntel 0001792:0002266 Mhz
BIOS Version: TOSHIBA 1.40, 2010-06-17
Windows Directory: C:\WINDOWS
System Directory: C:\WINDOWS\system32
Boot Device: \Device\HarddiskVolume1
System Locale: en-us;English (United States)
Input Locale: en-us;English (United States)
Time Zone: (UTC-05:00) Eastern Time (US & Canada)
Total Physical Memory: 3,891 MB
Available Physical Memory: 1,512 MB
Virtual Memory: Max Size: 11,671 MB
Virtual Memory: Available: 8,234 MB
Virtual Memory: In Use: 3,437 MB
Page File Location(s): C:\pagefile.sys
Domain: WORKGROUP
Logon Server: \\TOSHIBA
Hotfix(s): 8 Hotfix(s) Installed.
                           [01]: KB3116900
                           [02]: KB3116908
                           [03]: KB3120677
                           [04]: KB3122947
                           [05]: KB3124200
                           [06]: KB3124262
                           [07]: KB3124263
                           [08]: KB3133431
Network Card(s): 2 NIC(s) Installed.
                           [01]: Realtek RTL8191SE Wireless LAN 802.11n PCI-E NIC
                                 Connection Name: Wireless Network Connection
                                 Status: Media disconnected
                           [02]: Realtek PCIe FE Family Controller
                                 Connection Name: Home Office
                                 DHCP Enabled: Yes
                                 DHCP Server: 192.168.0.1
                                 IP address(es)
                                 [01]: 192.168.0.151
                                 [02]: fe80::7ccc:25c1:bdb5:2623
Hyper-V Requirements: VM Monitor Mode Extensions: Yes
                           Virtualization Enabled In Firmware: Yes
                           Second Level Address Translation: Yes
                           Data Execution Prevention Available: Yes
TagsNo tags attached.
Fixed in Revision51563
LazTarget-
Widgetset
Attached Files

Activities

Bart Broersma

2016-01-28 19:33

reporter   ~0089481

Lazarus 1.7 r51439 FPC 3.0.0 i386-win32-win32/win64
Cannot reproduce.

Martin Friebe

2016-01-28 21:25

manager   ~0089484

Last edited: 2016-01-28 21:26

View 2 revisions

Cannot reproduce either.

What exactly means: "when Brackets highlight color is set forth time in a row"

- Do you change the color (which one(s)? fore, back or frame color)?
- Do you toggle one or more of the checkboxes? All checked; all unchecked; some on/off?

Attach your editorophions.xml

Describe the exact steps:
- Start IDE / open project (use one of the lazarus sample projects)
- Open options
- set checkbox "bracket hl, foreground" to checked, set fore color to blue.
....
Alternatively video your steps

--------------
Please also run the IDE in the debugger and reproduce.
To do so
- Menu tools > configure build lazarus
  In field options enter/add
    -gw -Criot -gh -O- -Sa -dSynAssert
  tick/check the checkbox or radiobutton "clean all"
  press "build" button
- If finished building, restart IDE (unless it restarted on its own already)
- open project ide/lazarus.lpi
- menu run > run (or F9)

A 2nd IDE opens, reproduce the error.

If the first IDE reports an error, open the stack window (menu view > debug windows), and copy the stack.

If the 2nd IDE hangs, without the first reporting an error, go to the first, press "pause" and get the stack

Buckwheat1

2016-02-04 16:22

reporter  

0029530.mp4 (1,319,657 bytes)

Buckwheat1

2016-02-04 16:23

reporter  

editoroptions.xml (2,767 bytes)

Buckwheat1

2016-02-04 16:25

reporter   ~0089763

I have uploaded a screencast (0029530.mp4) and editoroptions.xml.

Zeljan Rikalo

2016-02-04 17:04

reporter   ~0089765

Cannot reproduce here:
Lazarus 1.7 r51476 FPC 2.6.4 i386-linux-qt

Juha Manninen

2016-02-04 17:33

reporter   ~0089766

Last edited: 2016-02-04 17:36

View 2 revisions

I cannot reproduce either.
However Ondrej has improved the IDEMenu code since RC2 and r51246. Please try with the latest trunk. My prediction is that your problem is gone.
I hope all the relevant revisions are merged to 1.6.

Martin Friebe

2016-02-04 22:52

manager   ~0089774

Last edited: 2016-02-04 22:56

View 3 revisions

-gttt -gh

and the error happens first time I close the option dialog with "ok"

0 ?? at :0
1 DOONUPDATE(0x1155bcd0) at idecommands.pas:1435
2 DOONUPDATE(0x1144fb10) at idecommands.pas:1189
3 EXECUTEUPDATEEVENTS(0xf94f9a0) at idecommands.pas:1541
4 APPLICATIONONIDLE(0xf94f9a0, 0x21ff18, true) at idecommands.pas:1511
5 NOTIFYIDLEHANDLER(0x21ff18, true) at include\application.inc:682
6 IDLE(0x21ff18, true) at include\application.inc:395
7 HANDLEMESSAGE(0x21ff18) at include\application.inc:1261
8 RUNLOOP(0x21ff18) at include\application.inc:1395
9 APPRUN(0x277d08, {Proc = {procedure (POINTER)} 0xde6fee8, Self = 0x21ff18}) at include\interfacebase.inc:54
10 RUN(0x21ff18) at include\application.inc:1383
11 main at lazarus.pp:140

something freed a keyshortcut, that is still referred by the category 'User defined word markup'


That means the attached editor opts are required too.

I also used (environment) HEAPTRC=keepreleased not sure if needed

Martin Friebe

2016-02-10 07:40

manager   ~0089910

Please test and close if ok

Buckwheat1

2017-12-12 18:20

reporter   ~0104662

The following version does not have the issue:

Lazarus version: 1.6.4
Lazarus svn revision: 54278
Lazarus build date: 2017/08/11
Lazarus was compiled for x86_64-win64
Lazarus was compiled with fpc 3.0.2

Issue History

Date Modified Username Field Change
2016-01-28 16:18 Buckwheat1 New Issue
2016-01-28 19:33 Bart Broersma Note Added: 0089481
2016-01-28 21:25 Martin Friebe Note Added: 0089484
2016-01-28 21:26 Martin Friebe Note Edited: 0089484 View Revisions
2016-01-28 23:52 Martin Friebe LazTarget => -
2016-01-28 23:52 Martin Friebe Assigned To => Martin Friebe
2016-01-28 23:52 Martin Friebe Status new => feedback
2016-02-04 16:22 Buckwheat1 File Added: 0029530.mp4
2016-02-04 16:23 Buckwheat1 File Added: editoroptions.xml
2016-02-04 16:25 Buckwheat1 Note Added: 0089763
2016-02-04 16:25 Buckwheat1 Status feedback => assigned
2016-02-04 17:04 Zeljan Rikalo Note Added: 0089765
2016-02-04 17:33 Juha Manninen Note Added: 0089766
2016-02-04 17:36 Juha Manninen Note Edited: 0089766 View Revisions
2016-02-04 22:52 Martin Friebe Note Added: 0089774
2016-02-04 22:53 Martin Friebe Summary Lazarus stops responding and "dies" when Brackets highlight color is set forth time in a row. => idecommands crash, when closing options dlg [Lazarus stops responding and "dies" when Brackets highlight]
2016-02-04 22:54 Martin Friebe Note Edited: 0089774 View Revisions
2016-02-04 22:54 Martin Friebe Assigned To Martin Friebe =>
2016-02-04 22:56 Martin Friebe Note Edited: 0089774 View Revisions
2016-02-10 07:38 Martin Friebe Assigned To => Martin Friebe
2016-02-10 07:40 Martin Friebe Fixed in Revision => 51563
2016-02-10 07:40 Martin Friebe Widgetset Win32/Win64 =>
2016-02-10 07:40 Martin Friebe Note Added: 0089910
2016-02-10 07:40 Martin Friebe Status assigned => resolved
2016-02-10 07:40 Martin Friebe Fixed in Version => 1.7 (SVN)
2016-02-10 07:40 Martin Friebe Resolution open => fixed
2016-02-10 07:40 Martin Friebe Target Version => 1.6
2017-12-12 18:20 Buckwheat1 Note Added: 0104662
2017-12-12 18:20 Buckwheat1 Status resolved => closed