View Issue Details

IDProjectCategoryView StatusLast Update
0029664LazarusIDEpublic2020-06-06 03:45
ReporterRussel Dirks Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Summary0029664: Shift-Tab does not always un-indent
DescriptionShift-Tab WILL unindent blocks of text, and lines that are selected. However it will not unindent a line of text that is unselected. Ctrl-U, on the other hand, will. Explicitly assigning Shift-Tab as the Undindent Block command does not help. It still will not unindent an unselected line of text.
Steps To Reproduce1. Place the cursor at the beginning of a line
2. Press shift-tab
3. the line does not un-indent
4. if the line is selected, it does
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0029591 assignedMartin Friebe Selected blocks of text do not indent properly with Tab 

Activities

Martin Friebe

2016-02-16 23:26

manager   ~0090087

When shift tab is not assigned to "unindent", this is the intended behaviour.

Shift-tab (with no selection) currently does nothing.
The desired behaviour, should be to "move the caret left, to the next tab pos"

That is if tab is set to 4 spaces, and you are on pos 11, then shift tab takes you to 9 (1+8), then 5 and then 1.
Optional, if the caret is within the leading spaces of the line (or even exactly after the leading spaces), then unindent may occur.

This is not yet implemented.

-------------------
Assigning the shift-tab key directly to the "unindent".

This needs to be fixed.

Martin Friebe

2018-01-31 04:34

manager   ~0106136

Last edited: 2018-01-31 04:35

View 3 revisions

I have tried to reproduce the issue of assigning shift-tab directly to "unindent block"

It works as expected. Caret can be anywhere on the line (including start of line), no selection needed, and unindent happens.

If you can still reproduce the issue (with 1.8 or trunk) then please attach your EditorOpitons.xml
The file can be found in your primary config path, usually
C:\Users\USERNAME\AppData\Local\lazarus
~/.lazarus


Please also specify your OS.

Martin Friebe

2020-06-06 03:45

manager   ~0123249

no feedback received / unable to reproduce.

If the issue still exists in Lazarus 2.0.8 please re-open this issue.
In this case:
- Please provide any feedback available.
- Please provide a copy of your EditorOptions.xml

Issue History

Date Modified Username Field Change
2016-02-16 22:33 Russel Dirks New Issue
2016-02-16 23:15 Martin Friebe Assigned To => Martin Friebe
2016-02-16 23:15 Martin Friebe Status new => assigned
2016-02-16 23:26 Martin Friebe Note Added: 0090087
2017-12-14 17:28 Juha Manninen Relationship added related to 0029591
2018-01-31 04:34 Martin Friebe LazTarget => -
2018-01-31 04:34 Martin Friebe Note Added: 0106136
2018-01-31 04:34 Martin Friebe Status assigned => feedback
2018-01-31 04:35 Martin Friebe Note Edited: 0106136 View Revisions
2018-01-31 04:35 Martin Friebe Note Edited: 0106136 View Revisions
2020-06-06 03:45 Martin Friebe Status feedback => resolved
2020-06-06 03:45 Martin Friebe Resolution open => unable to reproduce
2020-06-06 03:45 Martin Friebe Note Added: 0123249