View Issue Details

IDProjectCategoryView StatusLast Update
0029679FPCRTLpublic2016-02-19 16:17
Reporterqptain Nemo Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSLinux 
Product Version3.0.0 
Summary0029679: CRT unit strangely alters behavior of Writeln on Linux
DescriptionSee the attached program. The behavior described below is immediately apparent if you pipe the output to a text file.

After line 25 the writeln call starts adding unnecessary CR (13) characters at the end of strings after LF (10), which is invalid and if piped results in text files that have extra empty lines. Without the CRT unit the issue doesn't manifest.
Steps To Reproduceuses Crt;
var i : dword;
begin
for i:=1 to 30 do begin
  writeln('test');
  end;
end.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0018037 resolvedJonas Maebe unit crt cause the display shift right 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-02-19 15:36 qptain Nemo New Issue
2016-02-19 16:17 Jonas Maebe Relationship added duplicate of 0018037
2016-02-19 16:17 Jonas Maebe Status new => resolved
2016-02-19 16:17 Jonas Maebe Resolution open => duplicate
2016-02-19 16:17 Jonas Maebe Assigned To => Jonas Maebe