View Issue Details

IDProjectCategoryView StatusLast Update
0029717FPCFCLpublic2019-12-17 22:29
ReporterJulian Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformX64OSWindows 7 
Target Version3.0.2Fixed in Version3.1.1 
Summary0029717: TSimpleIPC Communication not working anymore in Lazarus 1.6
DescriptionThe IPC Client does not find the IPC Server. See the example in uploaded file.
Steps To ReproduceTry a simple communication between SimpleIPC Client and Server
Additional InformationThe Feature was working in Lazarus 1.4.4 FPC 2.6.4
TagsNo tags attached.
Fixed in Revision33126
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0036454 assignedMarco van de Voort 0029717: TSimpleIPC Communication not working anymore since Lazarus 1.6 

Activities

Julian

2016-02-24 13:03

reporter  

TsimpleIPC Test.zip (255,670 bytes)

Denis Kozlov

2016-02-24 18:50

reporter   ~0090249

Last edited: 2016-02-24 18:53

View 2 revisions

The problem originates from:

Revision: 30303
Author: michael
Date: 24 March 2015 09:16:44
Message:
* Fix Active:=true at designtime
----
Modified : /trunk/packages/fcl-process/src/simpleipc.pp

TSimpleIPC.Active is essentially not doing anything because component has csLoading in ComponentState.

It looks like csLoading is never removed from ComponentState.

It may also need to check for csDesigning.

Denis Kozlov

2016-02-24 18:56

reporter   ~0090250

Last edited: 2016-02-24 19:09

View 2 revisions

Found the problem...

TSimpleIPC.Loaded is not calling inherited TComponent.Loaded, which excludes csLoading from ComponentState.

This affects 3.0.0 and TRUNK.

Michael Van Canneyt

2016-02-27 10:21

administrator   ~0090377

I added the 'inherited' call. Please test and close if OK.

Issue History

Date Modified Username Field Change
2016-02-24 13:03 Julian New Issue
2016-02-24 13:03 Julian File Added: TsimpleIPC Test.zip
2016-02-24 18:50 Denis Kozlov Note Added: 0090249
2016-02-24 18:53 Denis Kozlov Note Edited: 0090249 View Revisions
2016-02-24 18:56 Denis Kozlov Note Added: 0090250
2016-02-24 19:09 Denis Kozlov Note Edited: 0090250 View Revisions
2016-02-26 00:21 Michael Van Canneyt Assigned To => Michael Van Canneyt
2016-02-26 00:21 Michael Van Canneyt Status new => assigned
2016-02-26 00:21 Michael Van Canneyt Project Lazarus => FPC
2016-02-27 10:21 Michael Van Canneyt Fixed in Revision => 33126
2016-02-27 10:21 Michael Van Canneyt Note Added: 0090377
2016-02-27 10:21 Michael Van Canneyt Status assigned => resolved
2016-02-27 10:21 Michael Van Canneyt Fixed in Version => 3.1.1
2016-02-27 10:21 Michael Van Canneyt Resolution open => fixed
2016-02-27 10:21 Michael Van Canneyt Target Version => 3.0.2
2019-12-17 22:29 Bart Broersma Relationship added related to 0036454