View Issue Details

IDProjectCategoryView StatusLast Update
0029824LazarusLCLpublic2017-01-25 20:45
Reporterjamie philbrookAssigned ToMichl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformintelOSWindowsOS Version7
Product Version1.4.2Product Buildboth 32/64 versions 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0029824: TTabControl TabWidth and TabHeigh work wrong
DescriptionThis seems to be an old problem..
TabWidth is ignored with tpTop but used as height
if tpLeft.
 
Incorrect operation.

Works correctly with Delphi.
 
Steps To ReproduceDrop a TTabControl on form, with TabPosition as tpTop.

Make a couple of tabs of what ever..
Try to set the TabWidth to any value, it gets ignored.
Now set TabPosition as tsleft, now Tabs are vertical and now
the TapWidth becomes Tab height and The actual TabHeight does nothing.

 I've look at the Setbounds code, it's incorrect operation as far as I am concerned.
TagsNo tags attached.
Fixed in Revision54002
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0031109 resolvedMichl Patches TabControl/PageControl: implemented TabWidth/TabHeight [win32] 

Activities

Bart Broersma

2016-03-13 18:35

developer   ~0090981

> Now set TabPosition as tsleft, now Tabs are vertical and now
> the TapWidth becomes Tab height

As strange as it may initially seem, there is some logic behind this.
Width = the length of the Tab in the direction of the Caption on it.

jamie philbrook

2016-03-13 19:02

reporter   ~0090983

I see the attempted logic but it does not follow the
Delphi paradigm.

 Its incorrect logic and you can't size the tabs to
fit other controls dynamically or static.

 Also I noticed the min size is a little over sized
when you have TabWidth set to 0, but that's not such a
big issue, the TabWidth not doing anything while its on
top/bottom is.
 
 If the Tabs are vertical, coders must think 90 degree
tilt. The width of a TAB is the same no matter what, for
vertical it simple looks like the Height is being changed but
its really the width using the TabWidth property..

 I really think this needs to be fixed

Alexey Tor.

2016-12-18 06:37

reporter   ~0096871

Last edited: 2016-12-18 06:37

View 2 revisions

May be changed - after 0031109 item will be applied
(TabWidth implementation)

Michl

2017-01-25 20:45

developer   ~0097704

Fixed for Win32 in trunk revision 54002. Please test and close if ok.

Issue History

Date Modified Username Field Change
2016-03-13 03:20 jamie philbrook New Issue
2016-03-13 18:35 Bart Broersma Note Added: 0090981
2016-03-13 19:02 jamie philbrook Note Added: 0090983
2016-12-18 06:37 Alexey Tor. Note Added: 0096871
2016-12-18 06:37 Alexey Tor. Note Edited: 0096871 View Revisions
2016-12-18 09:19 Juha Manninen Relationship added related to 0031109
2017-01-25 20:45 Michl Fixed in Revision => 54002
2017-01-25 20:45 Michl LazTarget => -
2017-01-25 20:45 Michl Note Added: 0097704
2017-01-25 20:45 Michl Status new => resolved
2017-01-25 20:45 Michl Fixed in Version => 1.7 (SVN)
2017-01-25 20:45 Michl Resolution open => fixed
2017-01-25 20:45 Michl Assigned To => Michl
2017-01-25 20:45 Michl Target Version => 1.8