View Issue Details

IDProjectCategoryView StatusLast Update
0029892FPCCompilerpublic2016-03-26 01:17
ReporterEmelyanov RomanAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx86_64OSWindowsOS Version7 and 10
Product Version3.1.1Product Build33324 
Target VersionFixed in Version 
Summary0029892: Building or cross-compiler from Windows to Linux is broken
DescriptionI try compile FPC from trunk with command like this "make all install clean FPC=C:\FPC\3.0.0\bin\x86_64-win64\ppcx64.exe" and its works. But if i try make crosscompiler with command like this "make all crossinstall clean OS_TARGET=linux FPC=C:\FPC\3.0.0\bin\x86_64-win64\ppcx64.exe" compilation failed with "system.pp(380,4) Fatal: Internal error 2015030501". This is old bug, its start about one year ago.

I tryed exploring this problem and find this. The source of bug is lack of define "FPC_HAS_TYPE_EXTENDED" or/and "cpuextended" with cross-compilation.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0009262 acknowledged No support for 80 bit softfloat in the compiler (needed for non-x86 to x86 crosscompiling) 

Activities

Florian

2016-03-25 09:02

administrator   ~0091370

This issue affects basically all combination of a host platform without extended support and a target platform which has an extended type (e. g. cross compiling from arm-linux to x86_64-linux will fail too). In your case, just use a 32 Bit compiler on windows, i386-win32 supports the extended type so the compiler can use it as well.

Emelyanov Roman

2016-03-26 01:17

reporter   ~0091413

I try 32-bit compiler to make crosscompiler and that works. Globally its bad, that produced crosscompiler binary is 32 bit. In any case, thanks for your answer.

Issue History

Date Modified Username Field Change
2016-03-24 23:30 Emelyanov Roman New Issue
2016-03-25 09:02 Florian Note Added: 0091370
2016-03-25 22:20 Jonas Maebe Relationship added duplicate of 0009262
2016-03-25 22:20 Jonas Maebe Status new => resolved
2016-03-25 22:20 Jonas Maebe Resolution open => duplicate
2016-03-25 22:20 Jonas Maebe Assigned To => Jonas Maebe
2016-03-26 01:17 Emelyanov Roman Note Added: 0091413
2016-03-26 01:17 Emelyanov Roman Status resolved => closed