View Issue Details

IDProjectCategoryView StatusLast Update
0029895LazarusLCLpublic2016-03-26 05:58
ReporterAlexey KamenskiyAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindowOS Version7
Product Version1.7 (SVN)Product Build52053 
Target Version1.8Fixed in Version1.8 
Summary0029895: In TDateEdit doesn't work today's date
DescriptionIf to choose today's date in TDateEdit date doesn't change
TagsNo tags attached.
Fixed in Revisionr52055
LazTarget1.8
WidgetsetWin32/Win64
Attached Files

Activities

Bart Broersma

2016-03-25 10:52

developer   ~0091375

I cannot reproduce.
Lazarus 1.7 r52015 FPC 3.0.0 i386-win32-win32/win64

Here's what I did.
TDateEdit, no text, DefaultToday = False
Query date -> 30-12-1899 (dd-mm-yyyy)
Click to open calendar, double click on the date of today (clicking on "Today" wil just select today's date, it wil not close the dialog, which AFAIK is by design)
Query date -> 25-03-2016 (which is today)

TDateEdit, no text, DefaultToday = True
Query date -> 25-03-2016 (dd-mm-yyyy)
Click to open calendar, double click on day before today
Query date -> 24-03-2016 (which is today)
Click to open calendar, double click on the date of today
Query date -> 25-03-2016 (which is today)


Please attach a minimal testcase (sources only) and describe the steps to reporduce this issue.

Alexey Kamenskiy

2016-03-25 11:59

reporter   ~0091377

In the previous version dialogue was closed clicking on "Today"

Bart Broersma

2016-03-25 12:58

developer   ~0091378

Last edited: 2016-03-25 13:03

View 2 revisions

AFAIR this was never the case.
Feel free to prove me wrong and find the revision that changed this behaviour.

Alexey Kamenskiy

2016-03-25 13:11

reporter   ~0091379

Took place. At the choice of today dialogue was closed and date was installed.

Bart Broersma

2016-03-25 13:23

developer   ~0091380

Please some more info:
Which revision/version worked like that?
Which revision broke it?

Bart Broersma

2016-03-25 13:46

developer   ~0091381

I see. 1.6 fixes behaves like that.
(By accident, because clicking on "Today" returned cpNowhere, which is wrong).

Bart Broersma

2016-03-25 13:46

developer   ~0091382

Please test and close if OK.

Alexey Kamenskiy

2016-03-26 05:58

reporter   ~0091415

Thanks

Issue History

Date Modified Username Field Change
2016-03-25 07:26 Alexey Kamenskiy New Issue
2016-03-25 10:52 Bart Broersma LazTarget => -
2016-03-25 10:52 Bart Broersma Note Added: 0091375
2016-03-25 10:52 Bart Broersma Assigned To => Bart Broersma
2016-03-25 10:52 Bart Broersma Status new => feedback
2016-03-25 11:59 Alexey Kamenskiy Note Added: 0091377
2016-03-25 11:59 Alexey Kamenskiy Status feedback => assigned
2016-03-25 12:58 Bart Broersma Note Added: 0091378
2016-03-25 13:03 Bart Broersma Note Edited: 0091378 View Revisions
2016-03-25 13:03 Bart Broersma Status assigned => feedback
2016-03-25 13:11 Alexey Kamenskiy Note Added: 0091379
2016-03-25 13:11 Alexey Kamenskiy Status feedback => assigned
2016-03-25 13:23 Bart Broersma Note Added: 0091380
2016-03-25 13:23 Bart Broersma Status assigned => feedback
2016-03-25 13:46 Bart Broersma Note Added: 0091381
2016-03-25 13:46 Bart Broersma Fixed in Revision => r52055
2016-03-25 13:46 Bart Broersma LazTarget - => 1.8
2016-03-25 13:46 Bart Broersma Note Added: 0091382
2016-03-25 13:46 Bart Broersma Status feedback => resolved
2016-03-25 13:46 Bart Broersma Fixed in Version => 1.8
2016-03-25 13:46 Bart Broersma Resolution open => fixed
2016-03-25 13:46 Bart Broersma Target Version => 1.8
2016-03-26 05:58 Alexey Kamenskiy Note Added: 0091415
2016-03-26 05:58 Alexey Kamenskiy Status resolved => closed