View Issue Details

IDProjectCategoryView StatusLast Update
0029948LazarusLCLpublic2016-04-07 15:11
ReporterPeterX Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Summary0029948: GetTextMetrics() declaration - avoid unneccessary hint
Description{%MainUnit ../lclintf.pas}

Second paramter of GetTextMetrics()
in WINAPIH.INC is OUT, not VAR.


Please see from MSDN:

BOOL GetTextMetrics(
  _In_ HDC hdc,
  _Out_ LPTEXTMETRIC lptm
);
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

has duplicate 0031527 new var/out winapi parameters: GetCursorPos, GetCaretPos, GetWindowRect 

Activities

Ondrej Pokorny

2016-04-04 12:32

developer   ~0091736

I don't think this is wanted/needed.

Ondrej Pokorny

2016-04-07 15:11

developer   ~0091819

Yep. It will never be changed, see the reason: http://lists.lazarus.freepascal.org/pipermail/lazarus/2016-April/098145.html

Issue History

Date Modified Username Field Change
2016-04-02 19:56 PeterX New Issue
2016-04-02 20:28 Jonas Maebe Project FPC => Lazarus
2016-04-04 12:32 Ondrej Pokorny Note Added: 0091736
2016-04-07 15:10 Ondrej Pokorny Assigned To => Ondrej Pokorny
2016-04-07 15:10 Ondrej Pokorny Status new => assigned
2016-04-07 15:11 Ondrej Pokorny LazTarget => -
2016-04-07 15:11 Ondrej Pokorny Note Added: 0091819
2016-04-07 15:11 Ondrej Pokorny Status assigned => resolved
2016-04-07 15:11 Ondrej Pokorny Resolution open => not fixable
2017-03-13 11:28 Ondrej Pokorny Relationship added has duplicate 0031527