View Issue Details

IDProjectCategoryView StatusLast Update
0029966LazarusLazReportpublic2016-04-06 05:39
Reporterwsoft-huAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform1.6.0-FPC-3.0.0.OSWindowsOS Version10 x64
Product Version1.6Product Build 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0029966: Lazarus 1.6 will not display generated by the Report Lazarus 1.4
DescriptionLRE_OLDV25_FRF_READ:= True;
frReport1.LoadPreparedReport('test-Lazarus-1.4.4-FPC-2.6.4.frp');
frReport1.ShowPreparedReport;
Not show report

LRE_OLDV25_FRF_READ:= True;
frReport1.LoadPreparedReport('test-Lazarus-1.6.0-FPC-3.0.0.frp');
frReport1.ShowPreparedReport;
correct show

test attached
TagsNo tags attached.
Fixed in Revision52108
LazTarget1.8
WidgetsetWin32/Win64
Attached Files

Activities

wsoft-hu

2016-04-05 09:35

reporter  

lazreport-test.zip (133,315 bytes)

wsoft-hu

2016-04-05 09:35

reporter  

1.PNG (39,556 bytes)
1.PNG (39,556 bytes)

wsoft-hu

2016-04-05 09:35

reporter  

2.PNG (52,011 bytes)
2.PNG (52,011 bytes)

Maxim Ganetsky

2016-04-05 14:55

developer   ~0091758

So it did not work in Lazarus 1.4.4 and works in Lazarus 1.6.0?

What is the point of this bug report then? Note that Lazarus 1.4 series is not supported anymore.

wsoft-hu

2016-04-05 15:03

reporter   ~0091759

Lazarus 1.6 will not display generated by the Report Lazarus 1.4

Bart Broersma

2016-04-05 15:08

developer   ~0091761

Updated summary.
@wsoft-hu: always fill in the summary of your report please!

Jesus Reyes

2016-04-05 23:39

developer   ~0091776

Last edited: 2016-04-06 05:39

View 2 revisions

Well, sadly I have to say, we did it again...

While LazReport was at binary format version=28 (or 27 don't know for sure) was active, a feature "ParagraphGap" was added without first increasing version to 29, because of that, some reports with version=28 (produced with Lazarus 1.4.4 for example) do not add or check for ParagraphGap but some other version=28 reports where saved with check for ParagraphGap. The result is that there is no way to distinguish which version=28 binary reports need to consume or ignore the ParagraphGap feature.

In the same way when v25 reports were broken, I solved the problem by adding a global variable LRE_OLDV28_FRF_READ which if set to true will allow LazReport to read those original version=28 reports, default is false. Additionally instead of showing a Access Violation dialog I added a message explaining the problem. Also by default, saving a prepared report will bring it's binary structure version up to the current version.

Please test.

Issue History

Date Modified Username Field Change
2016-04-05 09:35 wsoft-hu New Issue
2016-04-05 09:35 wsoft-hu File Added: lazreport-test.zip
2016-04-05 09:35 wsoft-hu File Added: 1.PNG
2016-04-05 09:35 wsoft-hu File Added: 2.PNG
2016-04-05 14:55 Maxim Ganetsky LazTarget => -
2016-04-05 14:55 Maxim Ganetsky Note Added: 0091758
2016-04-05 14:55 Maxim Ganetsky Status new => feedback
2016-04-05 15:03 wsoft-hu Note Added: 0091759
2016-04-05 15:03 wsoft-hu Status feedback => new
2016-04-05 15:08 Bart Broersma Note Added: 0091761
2016-04-05 15:08 Bart Broersma Summary - => Lazarus 1.6 will not display generated by the Report Lazarus 1.4
2016-04-05 18:26 Jesus Reyes Assigned To => Jesus Reyes
2016-04-05 18:26 Jesus Reyes Status new => assigned
2016-04-05 23:39 Jesus Reyes Fixed in Revision => 52108
2016-04-05 23:39 Jesus Reyes LazTarget - => 1.8
2016-04-05 23:39 Jesus Reyes Note Added: 0091776
2016-04-05 23:39 Jesus Reyes Status assigned => resolved
2016-04-05 23:39 Jesus Reyes Fixed in Version => 1.7 (SVN)
2016-04-05 23:39 Jesus Reyes Resolution open => fixed
2016-04-05 23:39 Jesus Reyes Target Version => 1.8
2016-04-06 05:39 Jesus Reyes Note Edited: 0091776 View Revisions