View Issue Details

IDProjectCategoryView StatusLast Update
0029978LazarusWidgetsetpublic2016-04-09 02:34
ReporterMark MalakanovAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64_86OSUbuntuOS Version14.2
Product Version1.6Product Build 
Target Version1.6.2Fixed in Version1.7 (SVN) 
Summary0029978: Sub-panel aligned in MDI form affects alignment/viewport of MDI children area.
DescriptionSub-panel aligned in MDI form affects alignment/viewport of MDI children area.

Steps To ReproduceCreate a form MDIForm, set FormStile to fsMDIForm.
Insert Panel1 aligned top or bottom.
Into Panel1 insert Panel2 aligned left or right.

Create a form MDIChild, set FormStile to fsMDIChild.

in MDIForm.FormCreate create MDIChild
in MDIForm.FormShow do MDIChild.Show, MDIForm.Tile

MDIChild will be aligned to Panel2.
TagsNo tags attached.
Fixed in Revision52148
LazTarget1.6.2
Widgetset
Attached Files

Activities

Mark Malakanov

2016-04-06 15:25

reporter  

MDIbug.zip (67,474 bytes)

Zeljan Rikalo

2016-04-08 13:14

developer   ~0091845

Please test and close if ok. Will be merged to 1.6.2

Mark Malakanov

2016-04-08 14:17

reporter   ~0091847

Hi Zeljan,
Thanks for fixing!

how can I test?
Could you provide with patch file?

Zeljan Rikalo

2016-04-08 14:48

developer   ~0091860

http://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/lcl/interfaces/qt/qtwidgets.pas?root=lazarus&r1=52054&r2=52148&pathrev=52148

AND

http://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/lcl/interfaces/qt/qtwidgets.pas?root=lazarus&r1=52148&r2=52149&pathrev=52149

On both click "Patch" and save it, then apply to your sources. Second patch is optimisation only.

Mark Malakanov

2016-04-09 02:34

reporter   ~0091868

Hi Zeljan,

I've applied first patch manually to 1.6.0.
it works!
I will close the case.

Thanks!

PS/ I am not sure what optimization the Second patch provides.
It looks like "undo" of the first.

Issue History

Date Modified Username Field Change
2016-04-06 15:24 Mark Malakanov New Issue
2016-04-06 15:25 Mark Malakanov File Added: MDIbug.zip
2016-04-06 16:22 Zeljan Rikalo Assigned To => Zeljan Rikalo
2016-04-06 16:22 Zeljan Rikalo Status new => assigned
2016-04-08 13:14 Zeljan Rikalo Fixed in Revision => 52148
2016-04-08 13:14 Zeljan Rikalo LazTarget => 1.6.2
2016-04-08 13:14 Zeljan Rikalo Note Added: 0091845
2016-04-08 13:14 Zeljan Rikalo Status assigned => resolved
2016-04-08 13:14 Zeljan Rikalo Fixed in Version => 1.7 (SVN)
2016-04-08 13:14 Zeljan Rikalo Resolution open => fixed
2016-04-08 13:14 Zeljan Rikalo Target Version => 1.6.2
2016-04-08 14:17 Mark Malakanov Note Added: 0091847
2016-04-08 14:48 Zeljan Rikalo Note Added: 0091860
2016-04-09 02:34 Mark Malakanov Note Added: 0091868