View Issue Details

IDProjectCategoryView StatusLast Update
0029982LazarusIDEpublic2016-09-30 14:44
ReporterFelipe Monteiro de CarvalhoAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel i7OSWindows 7 64-bitsOS Version
Product VersionProduct Build 
Target Version1.6.2Fixed in Version1.7 (SVN) 
Summary0029982: Code Editor hints completely broken (regression, FPC 2.6.4)
DescriptionSteps to reproduce:

1> Open Lazarus IDE
2> Keep the mouse over any kind of variable

Expected result:

A popup hint

Actual result:

Nothing, sometimes an "Out of memory" exception.

Rev 51386 -> Hint works fine
in between cannot compile
Revision 51434 -> Hint broken

Compilation broken here:
________________________________
Revision 51387 - (view) (download) (as text) - [select for diffs]
Added Sat Jan 23 17:20:09 2016 UTC (2 months, 1 week ago) by juha
File length: 4906 byte(s)

Turbopower_ipro: New files for Iphttpbroker and its example from
Silvio Clécio. Issue 0029483.

Compilation Fixed here:

Revision 51434 - (view) (download) (as text) - [select for diffs]
Modified Thu Jan 28 11:41:03 2016 UTC (2 months, 1 week ago) by juha
File length: 4976 byte(s)
Diff to previous 51387

Turbopower IPro: Fix compilation with FPC 2.6.4. Issue 0029483, patch
from Silvio Clécio.
TagsNo tags attached.
Fixed in Revision52141
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Felipe Monteiro de Carvalho

2016-04-07 10:57

developer   ~0091811

It seams that 51431 is the responsible revision: http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=revision&root=lazarus&revision=51431

Ondrej Pokorny

2016-04-07 11:41

developer   ~0091814

It looks like CodeTools fail to support nested functions.

It would be better to add nested function support to CodeTools (at least so that they don't kill the IDE) than just to omit them in the code.

Because the next time somebody decides to use them, we'll have the same problem.

Issue History

Date Modified Username Field Change
2016-04-07 10:54 Felipe Monteiro de Carvalho New Issue
2016-04-07 10:57 Felipe Monteiro de Carvalho Note Added: 0091811
2016-04-07 11:16 Felipe Monteiro de Carvalho Fixed in Revision => 52141
2016-04-07 11:16 Felipe Monteiro de Carvalho Status new => resolved
2016-04-07 11:16 Felipe Monteiro de Carvalho Resolution open => fixed
2016-04-07 11:16 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2016-04-07 11:41 Ondrej Pokorny Note Added: 0091814
2016-09-30 14:44 Ondrej Pokorny Fixed in Version => 1.7 (SVN)
2016-09-30 14:44 Ondrej Pokorny Target Version => 1.6.2