View Issue Details

IDProjectCategoryView StatusLast Update
0030013LazarusOtherpublic2017-07-26 04:19
ReporterMilošAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.6Product Build51630 2016-02-14 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0030013: i18n do not translate TDBGrid TColumn.Title.Caption
DescriptionPlease test attached application.
Steps To ReproduceAdd field to DBGrid1 and complite application.
TagsNo tags attached.
Fixed in Revision52216
LazTarget1.6.2
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0029763 resolvedJesus Reyes TDBGrid.Columns.Title.Caption do not save to LRT file, not save to PO file and not translate 

Activities

Miloš

2016-04-14 20:32

reporter  

dbgridlang.zip (132,010 bytes)

wp

2016-04-14 21:19

developer   ~0092042

The issue seems to be inherited from TCustomGrid since the column titles of TStringGrid.Columns are missing from the po file as well. TListView.Columns and THeader.Sections, on the other hand, having a different inheritance are working correctly. I changed the type of TGridColumn.Title.Caption to be TTranslateString (which is used by TListColumn.Caption) instead of TCaption but this did not solve the issue.

Jesus Reyes

2016-04-19 22:44

developer   ~0092102

Please test.

Miloš

2017-07-25 22:36

reporter   ~0101914

The problem persists in Lazarus IDE 1.8 RC3 (FPC 3.0.2).

What is fixed FPC version?

Jesus Reyes

2017-07-26 04:19

developer   ~0101918

The .lrt file support has been dropped. Instead a .lrj should be created together with a .po file and it does here, at least in trunk version.

Issue History

Date Modified Username Field Change
2016-04-14 20:32 Miloš New Issue
2016-04-14 20:32 Miloš File Added: dbgridlang.zip
2016-04-14 21:19 wp Note Added: 0092042
2016-04-15 21:51 Jesus Reyes Relationship added duplicate of 0029763
2016-04-15 21:51 Jesus Reyes Assigned To => Jesus Reyes
2016-04-15 21:51 Jesus Reyes Status new => assigned
2016-04-19 22:44 Jesus Reyes Fixed in Revision => 52216
2016-04-19 22:44 Jesus Reyes LazTarget => 1.6.2
2016-04-19 22:44 Jesus Reyes Note Added: 0092102
2016-04-19 22:44 Jesus Reyes Status assigned => resolved
2016-04-19 22:44 Jesus Reyes Fixed in Version => 1.7 (SVN)
2016-04-19 22:44 Jesus Reyes Resolution open => fixed
2016-04-19 22:44 Jesus Reyes Target Version => 1.8
2017-07-25 22:36 Miloš Note Added: 0101914
2017-07-26 04:19 Jesus Reyes Note Added: 0101918