View Issue Details

IDProjectCategoryView StatusLast Update
0030031LazarusLCLpublic2017-02-10 17:23
ReporterMiloŇ°Assigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.6Product Build51630 2016-02-14 
Target Version1.6.2Fixed in Version1.6.2 
Summary0030031: i18n generates text Ok and Cancel to translate from TDateEdit
DescriptionThis texts are not exist in TDateEdit and these captions are generated in PO file for translate.
Steps To ReproduceAdd TDateEdit to form and compile application. Check PO file.
TagsNo tags attached.
Fixed in Revisionr52760
LazTarget1.6.2
WidgetsetWin32/Win64
Attached Files

Activities

wp

2016-04-18 23:38

developer   ~0092083

These strings enter the po file because the component publishes the properties "CancelCaption" and "OkCaption". But I think they are not needed anywhere as the calendar popup only contains the calendar control, but it does not contain neither a Cancel nor an OK button.

Bart Broersma

2016-07-31 16:30

developer   ~0093918

This is a remnat from the time a TCalendarDialog was shown.
It was introduced in revision 6842 by Mattias.

The property should be removed, but that will lead to errors loading the component.

Bart Broersma

2016-07-31 17:09

developer   ~0093920

Please test and close if OK.

Issue History

Date Modified Username Field Change
2016-04-18 22:12 MiloŇ° New Issue
2016-04-18 23:38 wp Note Added: 0092083
2016-07-31 16:30 Bart Broersma Note Added: 0093918
2016-07-31 16:41 Bart Broersma Assigned To => Bart Broersma
2016-07-31 16:41 Bart Broersma Status new => assigned
2016-07-31 17:09 Bart Broersma Fixed in Revision => r52760
2016-07-31 17:09 Bart Broersma LazTarget => 1.6.2
2016-07-31 17:09 Bart Broersma Note Added: 0093920
2016-07-31 17:09 Bart Broersma Status assigned => resolved
2016-07-31 17:09 Bart Broersma Fixed in Version => 1.6.2
2016-07-31 17:09 Bart Broersma Resolution open => fixed
2016-07-31 17:09 Bart Broersma Target Version => 1.6.2