View Issue Details

IDProjectCategoryView StatusLast Update
0030132LazarusIDEpublic2016-08-03 14:12
ReporterDmitry D. ChernovAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386-win32OSWindowsOS VersionXP SP3 x86
Product Version1.6Product Build51630 (2016-02-23) 
Target VersionFixed in Version1.6.2 
Summary0030132: "List index out of bounds" error
DescriptionAfter I've done some work in Lazarus, I tried to close one of the tabs in the Code Editor, and error occurred when I pressed right moube button to show context menu:

List index (5) out of bounds.

I've determined that this bug doesn't vanishes after reloading the project, so I attached it to help developers reproduce the bug.
Steps To Reproduce1. Open an attached project.
2. Try to close tab in the Code Editor from context menu.
Additional InformationScreenshot of the exception is also attached.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Dmitry D. Chernov

2016-05-13 17:11

reporter  

bug_project.7z (121,245 bytes)

Dmitry D. Chernov

2016-05-13 17:11

reporter  

2016-05-13_220907.png (11,104 bytes)
2016-05-13_220907.png (11,104 bytes)

Ondrej Pokorny

2016-05-14 15:08

reporter   ~0092560

I cannot reproduce. There is only 1 tab open. I can close it and the source editor closes as well.

Martin Friebe

2016-05-14 16:32

manager   ~0092562

It happens in 1.6, but not in 1.7
Not tested on 1.6.1

#0 RAISEGDBEXCEPTION(0xfae558 'TIDEMenuSection.UpdateNeedTopSeparator inconsistency') at lclproc.pas:902
0000001 UPDATENEEDTOPSEPARATOR(0xd78f440) at menuintf.pas:996
0000002 TIDEMENUSECTION__UPDATEMENUSTRUCTURE(<error reading variable>) at menuintf.pas:1107
0000003 TIDEMENUSECTION__ITEMVISIBLEACTIVECHANGED(0xfb777d0, <error reading variable>) at menuintf.pas:1271
0000004 TIDEMENUSECTION__INSERT(0, 0xfb777d0, <error reading variable>) at menuintf.pas:1344
0000005 TIDEMENUSECTION__ADDLAST(0xfb777d0, <error reading variable>) at menuintf.pas:1333
0000006 REGISTERIDEMENUCOMMAND(0x1037da60, 0x10616bdc 'Open lpk C:\lazarus\lcl\lclbase.lpk', 0xf59e18 'Open package', 0x7d7720 <TSOURCENOTEBOOK__ONPOPUPOPENPACKAGEFILE>, 0x0, 0x0, 0x0, 258213376) at menuintf.pas:522
0000007 TSOURCENOTEBOOK__TABPOPUPMENUPOPUP(0x104f1670, <error reading variable>) at sourceeditor.pp:6617
0000008 TPOPUPMENU__DOPOPUP(0x104f1670, <error reading variable>) at .\include\popupmenu.inc:37
0000009 TPOPUPMENU__POPUP(-950, 186, <error reading variable>) at .\include\popupmenu.inc:74
0000010 TCONTROL__WMCONTEXTMENU({MSG = 123, HWND = 133888, XPOS = -950, YPOS = 186, POS = {X = -950, Y = 186}, DUMMY = 12254282, RESULT = 0}, <error reading variable>) at .\include\control.inc:2271
0000011 TWINCONTROL__WMCONTEXTMENU({MSG = 123, HWND = 133888, XPOS = -950, YPOS = 186, POS = {X = -950, Y = 186}, DUMMY = 12254282, RESULT = 0}, <error reading variable>) at .\include\wincontrol.inc:8309
0000012 SYSTEM$_$TOBJECT_$__$$_DISPATCH$formal at :0
0000013 VMT_$CONTROLS_$$_TWINCONTROL at :0
0000014 ?? at :0
0000015 TWINCONTROL__WNDPROC({MSG = 123, WPARAM = 133888, LPARAM = 12254282, RESULT = 0, WPARAMLO = 2816, WPARAMHI = 2, WPARAMFILLER = {}, LPARAMLO = 64586, LPARAMHI = 186, LPARAMFILLER = {}, RESULTLO = 0, RESULTHI = 0, RESULTFILLER = {}}, <error reading variable>) at .\include\wincontrol.inc:5383
0000016 DELIVERMESSAGE(0x105a3870, <error reading variable: Attempt to dereference a generic pointer.>) at lclmessageglue.pas:112
0000017 TWINDOWPROCHELPER__DOWINDOWPROC(<error reading variable>) at win32callback.inc:2423
0000018 WINDOWPROC(133888, 123, 133888, 12254282) at win32callback.inc:2586
0000019 USER32!GetWindowLongW at :0
0000020 ?? at :0
0000021 USER32!GetWindowLongW at :0
0000022 TWINDOWPROCHELPER__DOWINDOWPROC(<error reading variable>) at win32callback.inc:2556
0000023 USER32!ReleaseDC at :0
0000024 WCSToMBEx at :0
0000025 ntdll!KiUserCallbackDispatcher at :0
0000026 ?? at :0
0000027 USER32!DispatchMessageW at :0
0000028 USER32!DefWindowProcW at :0
0000029 ?? at :0
0000030 ImageList_AddIcon at :0
0000031 USER32!GetWindowLongW at :0
0000032 ?? at :0
0000033 USER32!GetWindowLongW at :0
0000034 ImageList_AddIcon at :0
0000035 USER32!CallWindowProcW at :0
0000036 USER32!CallWindowProcW at :0
0000037 CALLDEFAULTWINDOWPROC(133888, 517, 0, 590031) at win32callback.inc:100
0000038 TWINDOWPROCHELPER__DOWINDOWPROC(<error reading variable>) at win32callback.inc:2492
0000039 WINDOWPROC(133888, 517, 0, 590031) at win32callback.inc:2586
0000040 USER32!GetWindowLongW at :0
0000041 ?? at :0
0000042 USER32!GetWindowLongW at :0
0000043 TWINDOWPROCHELPER__DOWINDOWPROC(<error reading variable>) at win32callback.inc:2556
0000044 USER32!GetMessageW at :0
0000045 USER32!DispatchMessageW at :0
0000046 TWIN32WIDGETSET__APPPROCESSMESSAGES(<error reading variable>) at win32object.inc:366
0000047 TAPPLICATION__HANDLEMESSAGE(<error reading variable>) at .\include\application.inc:1260
0000048 TAPPLICATION__RUNLOOP(<error reading variable>) at .\include\application.inc:1395
0000049 TWIDGETSET__APPRUN(0x4384d0 <TAPPLICATION__RUNLOOP>, <error reading variable>) at .\include\interfacebase.inc:54
0000050 TAPPLICATION__RUN(<error reading variable>) at .\include\application.inc:1383
0000051 main at lazarus.pp:140

Martin Friebe

2016-05-14 16:56

manager   ~0092563

Tested with 1.6.1, and works well.

The issue was fixed already in the meantime, and the fix will be in the next release (1.6.2).

If 1.6.2 (once released) does not fix this for you, then please reopen.

Arent

2016-07-27 14:35

reporter   ~0093856

Last edited: 2016-07-27 14:50

View 2 revisions

Lazarus 1.6.0.4 crashes frequently on Windows32 and Linux in the next scenario:
* try to open the context-menu with right-click on the tab
* List index (4) out of bounds
Crash is more likely to occur if one or more other tabs were closed recently someway

Martin Friebe

2016-07-27 14:43

manager   ~0093857

@Arent.

This issue was fixed and resolved.
Please open a new issue. Please attach stack traces. Also test with trunk, maybe it is fixed there.

Btw what is Lazarus 1.6.0.4 ? This is not distributed by us.

------------
If not fixed in trunk, all answers in a NEW issue please.
Answers on this (resolved/closed) issue, may be overlooked easily.

Arent

2016-07-27 15:52

reporter   ~0093859

@Martin
I thought 1.6.0.4 was in the message window header but can't reproduce.

Running SVN 51630 on windows and Debian package 1.6+dfsg-1 x86_64-linux-gtk 2 on Linux Mint 18.

Issue History

Date Modified Username Field Change
2016-05-13 17:11 Dmitry D. Chernov New Issue
2016-05-13 17:11 Dmitry D. Chernov File Added: bug_project.7z
2016-05-13 17:11 Dmitry D. Chernov File Added: 2016-05-13_220907.png
2016-05-14 15:08 Ondrej Pokorny Note Added: 0092560
2016-05-14 16:32 Martin Friebe Note Added: 0092562
2016-05-14 16:56 Martin Friebe LazTarget => -
2016-05-14 16:56 Martin Friebe Note Added: 0092563
2016-05-14 16:56 Martin Friebe Status new => resolved
2016-05-14 16:56 Martin Friebe Fixed in Version => 1.6.2
2016-05-14 16:56 Martin Friebe Resolution open => fixed
2016-05-14 16:56 Martin Friebe Assigned To => Martin Friebe
2016-07-27 14:35 Arent Note Added: 0093856
2016-07-27 14:43 Martin Friebe Note Added: 0093857
2016-07-27 14:50 Arent Note Edited: 0093856 View Revisions
2016-07-27 15:52 Arent Note Added: 0093859
2016-08-03 14:12 Dmitry D. Chernov Status resolved => closed