View Issue Details

IDProjectCategoryView StatusLast Update
0030160LazarusLCLpublic2016-05-20 13:37
ReporterLagunov Aleksey Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
OSLinux 
Product Version1.7 (SVN) 
Summary0030160: DBGrid flickering on open empty dataset after rev 52322.
DescriptionDBGrid flickering on open empty dataset after rev 52322. On rev 52321 work normal.

Steps To ReproduceRun demo. Or set in designer time MemDataset1.Active to true.
TagsNo tags attached.
Fixed in Revision52333
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Lagunov Aleksey

2016-05-20 07:33

reporter  

Demo_70_TestErrorGrid.zip (130,317 bytes)

Ondrej Pokorny

2016-05-20 11:16

developer   ~0092646

I cannot reproduce on Windows 10.

How does the flickering exhibit? What do you do? What OS?

Lagunov Aleksey

2016-05-20 11:48

reporter   ~0092648

Fedora 23 x64 GTK2

Lazarus 1.7 r52322M FPC 3.1.1 x86_64-linux-gtk 2

Ondrej Pokorny

2016-05-20 13:17

developer   ~0092650

Please test.

Lagunov Aleksey

2016-05-20 13:37

reporter   ~0092653

all ok. work normal.

Issue History

Date Modified Username Field Change
2016-05-20 07:33 Lagunov Aleksey New Issue
2016-05-20 07:33 Lagunov Aleksey File Added: Demo_70_TestErrorGrid.zip
2016-05-20 11:12 Ondrej Pokorny Assigned To => Ondrej Pokorny
2016-05-20 11:12 Ondrej Pokorny Status new => assigned
2016-05-20 11:16 Ondrej Pokorny Note Added: 0092646
2016-05-20 11:48 Lagunov Aleksey Note Added: 0092648
2016-05-20 13:17 Ondrej Pokorny Fixed in Revision => 52333
2016-05-20 13:17 Ondrej Pokorny LazTarget => -
2016-05-20 13:17 Ondrej Pokorny Widgetset => GTK 2
2016-05-20 13:17 Ondrej Pokorny Note Added: 0092650
2016-05-20 13:17 Ondrej Pokorny Status assigned => resolved
2016-05-20 13:17 Ondrej Pokorny Resolution open => fixed
2016-05-20 13:18 Ondrej Pokorny OS => Linux
2016-05-20 13:37 Lagunov Aleksey Note Added: 0092653
2016-05-20 13:37 Lagunov Aleksey Status resolved => closed