View Issue Details

IDProjectCategoryView StatusLast Update
0030234LazarusLCLpublic2020-04-09 18:32
ReporterMaxim Ganetsky Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32OSWindows 
Product Version1.7 (SVN) 
Summary0030234: TListView: pressed keys are not reflected in Shift variable inside OnMouseUp event
DescriptionWhen using TListView, pressed keys are not reflected in Shift variable inside OnMouseUp event. They are reflected OK in OnMouseDown/OnMouseMove events, though.
Steps To Reproduce1. Compile and run attached example.
2. Press and keep pressed Shift key.
3. Click inside ListView, but not on items. Shift state is detected OK in all three events.
4. Click on any ListView item. Shift state is not detected in OnMouseUp event.
Additional InformationI use FPC 3.0.0. Bug can be reproduced in Lazarus 1.6.1 too.
TagsNo tags attached.
Fixed in Revision52440
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0035362 resolvedMartin Friebe ListView with MultiSelect incorrectly deselects items on MouseDown 

Activities

Maxim Ganetsky

2016-06-03 00:57

developer  

listview_test.zip (5,428 bytes)

Ondrej Pokorny

2016-06-05 03:37

developer   ~0093024

It looks like Windows issue - Delphi is affected by the same problem.

Fixed with a workaround.

Maxim Ganetsky

2016-06-05 23:55

developer   ~0093054

It works, thanks!

Issue History

Date Modified Username Field Change
2016-06-03 00:57 Maxim Ganetsky New Issue
2016-06-03 00:57 Maxim Ganetsky File Added: listview_test.zip
2016-06-03 01:30 Maxim Ganetsky Reproducibility have not tried => always
2016-06-03 13:35 Maxim Ganetsky Steps to Reproduce Updated View Revisions
2016-06-05 03:36 Ondrej Pokorny Assigned To => Ondrej Pokorny
2016-06-05 03:36 Ondrej Pokorny Status new => assigned
2016-06-05 03:37 Ondrej Pokorny Fixed in Revision => 52440
2016-06-05 03:37 Ondrej Pokorny Note Added: 0093024
2016-06-05 03:37 Ondrej Pokorny Status assigned => resolved
2016-06-05 03:37 Ondrej Pokorny Resolution open => fixed
2016-06-05 23:55 Maxim Ganetsky Note Added: 0093054
2016-06-05 23:55 Maxim Ganetsky Status resolved => closed
2020-04-09 18:32 Ondrej Pokorny Relationship added related to 0035362