View Issue Details

IDProjectCategoryView StatusLast Update
0030292FPCCompilerpublic2016-06-17 18:22
Reporterdoug telfordAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformx86_64OSUbuntuOS Version15.10
Product Version3.0.0Product Build2015/12/05 
Target VersionFixed in Version 
Summary0030292: linux command line compile, I always get the message : Did you forget -T?
DescriptionAll programs that I have tried get the compiler/loader message

/usr/bin/ld: warning: link.res contains output sections; did you forget -T?

This message is preceded by 20 blank lines.

The product should never had been released with this type of error. I will use the Windows version.
Steps To ReproduceCompile any fpc program from the command line on Ubuntu (of linux)
Tagslinker, linux, messages
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0027988 resolvedJonas Maebe Variable length line break during the phase of Linkage 

Activities

Jonas Maebe

2016-06-17 18:22

manager   ~0093270

The duplicate bug is about the blank lines, which is a bug in the linker that ships with your Ubuntu version, not in FPC. It is just a cosmetic problem, and does not affect the generated code.

The -T warning is also harmless, but fixed in trunk: http://wiki.freepascal.org/User_Changes_Trunk#GNU_Binutils_2.19.1_or_later_are_required_by_default

Issue History

Date Modified Username Field Change
2016-06-17 16:05 doug telford New Issue
2016-06-17 16:09 doug telford Tag Attached: linker
2016-06-17 16:09 doug telford Tag Attached: linux
2016-06-17 16:09 doug telford Tag Attached: messages
2016-06-17 18:22 Jonas Maebe Note Added: 0093270
2016-06-17 18:22 Jonas Maebe Relationship added duplicate of 0027988
2016-06-17 18:22 Jonas Maebe Status new => resolved
2016-06-17 18:22 Jonas Maebe Resolution open => duplicate
2016-06-17 18:22 Jonas Maebe Assigned To => Jonas Maebe