View Issue Details

IDProjectCategoryView StatusLast Update
0030392LazarusLazReportpublic2017-01-05 22:19
ReporterEdson LidorioAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindows 7OS VersionProfessional
Product Version1.6.1 (SVN)Product Build 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0030392: Lazreport not saving last property used in inspector object.
DescriptionLazreport not saving last property used in inspector object.
For example:

In the object inspector of Lazreport being selected a Memo1 on property Left to jump to Focus on property Left Memo2 is not preserved it goes to another property.
TagsNo tags attached.
Fixed in Revision53884
LazTarget1.8
Widgetset
Attached Files

Relationships

related to 0025845 closedJesus Reyes Lazreport losing focus of the selected property 

Activities

Edson Lidorio

2016-07-20 21:54

reporter  

Designer - Untitled.png (18,316 bytes)
Designer - Untitled.png (18,316 bytes)

Edson Lidorio

2016-12-25 18:44

reporter   ~0097077

For better understanding of the bug 0030392 that I reported, follows a small video [1] where demonstrates the problem.

Note the property "Top" is never selected to move to the next object Memo
[1] https://youtu.be/G2BzGPXuEGM

Edson Lidorio

2016-12-27 13:41

reporter   ~0097088

Checking the commits, this bug has been fixed and now was introduced again.
as below:
http://mantis.freepascal.org/view.php?id=25845

Jesus Reyes

2017-01-03 19:51

developer   ~0097276

Please test

Edson Lidorio

2017-01-04 14:25

reporter   ~0097288

There is also a small problem!
The last property is preserved, but the cursor is not preserved when changing memo object.

Jesus Reyes

2017-01-05 22:17

developer   ~0097323

Last edited: 2017-01-05 22:19

View 2 revisions

This sounds like "yes, it's now fixed but in addition there is some cursor bug". If this is so (it's my guess after all) then the property not being preserved bug is now fixed and this report must be closed.

Now, if the cursor thing your mention is caused by the fix, it makes sense to keep it within this report. But I don't really understand what you mean by "the cursor is not preserved", you mean the cursor property normally set to crDefault value? (unlikely) or to the text cursor (the text caret) that shows the location where the inserted text is expected to appear. If that is the case, then I'm afraid there is nothing there to fix (or maybe yes I don't know yet) becase I checked in the object inpector used in Lazarus Form Designer and it appears to work the same way. I mean, this is what I see: if the text cursor is at the end or in the middle of the edited text in the Object Inspector edit control and then you select another designer object that have the same edited property, then the text cursor will be at the begining of the edited text.

Please try to describe in more detail what is what you are looking at, how was before, how is now, what have changed, etc...

Issue History

Date Modified Username Field Change
2016-07-20 21:54 Edson Lidorio New Issue
2016-07-20 21:54 Edson Lidorio File Added: Designer - Untitled.png
2016-07-20 21:55 Jesus Reyes Assigned To => Jesus Reyes
2016-07-20 21:55 Jesus Reyes Status new => assigned
2016-12-25 18:44 Edson Lidorio Note Added: 0097077
2016-12-27 13:41 Edson Lidorio Note Added: 0097088
2017-01-02 19:04 Jesus Reyes Relationship added related to 0025845
2017-01-03 19:51 Jesus Reyes Fixed in Revision => 53884
2017-01-03 19:51 Jesus Reyes LazTarget => 1.8
2017-01-03 19:51 Jesus Reyes Note Added: 0097276
2017-01-03 19:51 Jesus Reyes Status assigned => resolved
2017-01-03 19:51 Jesus Reyes Fixed in Version => 1.7 (SVN)
2017-01-03 19:51 Jesus Reyes Resolution open => fixed
2017-01-03 19:51 Jesus Reyes Target Version => 1.8
2017-01-04 14:25 Edson Lidorio Note Added: 0097288
2017-01-05 22:17 Jesus Reyes Note Added: 0097323
2017-01-05 22:19 Jesus Reyes Note Edited: 0097323 View Revisions