View Issue Details

IDProjectCategoryView StatusLast Update
0030397PatchesIDEpublic2020-06-06 20:45
ReporterDarek Mazur Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version1.7 (SVN) 
Summary0030397: HTML syntax highlighting refine
Description attributes are not differentiate from key words,
  second: Escape_ampersand and comments are paint bold: that make noise.
Steps To ReproduceIndex: ColorDefault.xml
===================================================================
--- ColorDefault.xml (revision 52729)
+++ ColorDefault.xml (working copy)
@@ -84,9 +84,9 @@
       <LangHTML_document Version="6">
         <SchemeDefault>
           <Asp Background="clYellow" Foreground="clBlack"/>
- <Comment Foreground="clBlue" Style="fsBold"/>
- <Escape_ampersand Foreground="clLime" Style="fsBold"/>
- <Identifier Style="fsBold"/>
+ <Comment Foreground="clBlue"/>
+ <Escape_ampersand Foreground="clLime"/>
+ <Identifier Foreground="clMaroon"/>
           <Reserved_word Style="fsBold"/>
           <Symbol Foreground="clRed"/>
           <Unknown_word Foreground="clRed" Style="fsBold"/>
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Darek Mazur

2016-07-21 17:26

developer  

originalColorHtml.jpg (54,974 bytes)   
originalColorHtml.jpg (54,974 bytes)   

Darek Mazur

2016-07-21 17:26

developer  

myColorHTML.jpg (79,378 bytes)   
myColorHTML.jpg (79,378 bytes)   

Darek Mazur

2016-07-21 17:26

developer  

ColorDefault.xml.patch (756 bytes)   
Index: ColorDefault.xml
===================================================================
--- ColorDefault.xml	(revision 52729)
+++ ColorDefault.xml	(working copy)
@@ -84,9 +84,9 @@
       <LangHTML_document Version="6">
         <SchemeDefault>
           <Asp Background="clYellow" Foreground="clBlack"/>
-          <Comment Foreground="clBlue" Style="fsBold"/>
-          <Escape_ampersand Foreground="clLime" Style="fsBold"/>
-          <Identifier Style="fsBold"/>
+          <Comment Foreground="clBlue"/>
+          <Escape_ampersand Foreground="clLime"/>
+          <Identifier Foreground="clMaroon"/>
           <Reserved_word Style="fsBold"/>
           <Symbol Foreground="clRed"/>
           <Unknown_word Foreground="clRed" Style="fsBold"/>
ColorDefault.xml.patch (756 bytes)   

Martin Friebe

2016-07-21 18:56

manager   ~0093793

Just a personal comment on this. Changing defaults is a delicate issue. Those people currently using the defaults, will get / have gotten used to them.
Change can worsen the experience.

With either setting some people will be left to having to edit their settings/colors.

People who are used to > popping out of the text, might say that removing this reduces readability (well it does to them)
So I am not sure if that is a good step (for defaults). I would leave the defaults for that as they are.

Introducing colors for attributes is in some way like a new feature. So that is a change I think should make it.

On the change for comments I have no strong arguments for either way.
The ampersand argument could apply, but comments are often bigger (bigger than &0123;) and stand/pop out due to their size (the amount of text in diff color).
And that very size of them makes your "noise" argument more interesting. Small pieces of bold (&1234;) are less of an obstacle to read the text. Large pieces of bold indeed might be.

Darek Mazur

2016-07-22 11:19

developer   ~0093796

I agree. But my proposal applies to edit HTML, that is not common as PAS.
And second: changes are minimal: most not even notice this.
 
About noise: bold should be reserved to important things, keywords are the but comments (for me) not

And I don't understand sentence with ">", proposition don't change anything with it.

Martin Friebe

2016-07-22 13:00

manager   ~0093797

The sentence with the ">" referred to ampersand sequence.

I did type & gt ; but mantis appears to have converted this.

So basically I am ok with 2 of your changes, but sceptical about the 3rd (ampersand sequences).

Darek Mazur

2016-07-22 15:34

developer   ~0093798

1.should I prepare new patch
2.should patch cover other scheme (f.e. Delphi )

Juha Manninen

2016-09-19 12:20

developer   ~0094716

I think this should be either rejected or guidelines for a new patch should be given.

Martin Friebe

2020-06-06 20:45

manager   ~0123279

Not going to change the defaults. All values can be configured by the user.

Issue History

Date Modified Username Field Change
2016-07-21 17:26 Darek Mazur New Issue
2016-07-21 17:26 Darek Mazur File Added: originalColorHtml.jpg
2016-07-21 17:26 Darek Mazur File Added: myColorHTML.jpg
2016-07-21 17:26 Darek Mazur File Added: ColorDefault.xml.patch
2016-07-21 18:56 Martin Friebe Note Added: 0093793
2016-07-22 11:19 Darek Mazur Note Added: 0093796
2016-07-22 13:00 Martin Friebe Note Added: 0093797
2016-07-22 15:34 Darek Mazur Note Added: 0093798
2016-09-19 12:19 Juha Manninen Assigned To => Martin Friebe
2016-09-19 12:19 Juha Manninen Status new => assigned
2016-09-19 12:20 Juha Manninen Note Added: 0094716
2020-06-06 20:45 Martin Friebe Status assigned => resolved
2020-06-06 20:45 Martin Friebe Resolution open => won't fix
2020-06-06 20:45 Martin Friebe Widgetset Win32/Win64 => Win32/Win64
2020-06-06 20:45 Martin Friebe Note Added: 0123279