View Issue Details

IDProjectCategoryView StatusLast Update
0030490LazarusIDEpublic2018-01-17 19:02
ReporterHans LuijtenAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformCarbonOSMacOS XOS Version10.11
Product Version1.7 (SVN)Product Build52835 
Target VersionFixed in Version 
Summary0030490: Run without debugging: Cannot run compiled application from IDE (launching application invalid)
DescriptionIn Lazarus 1.7, SVN 52835, on MacOS X 10.11:

After compiling, an application cannot be run with the new "run without debugging" button.
See attached image.

This will always produce the same error message:

Launching application Invalid
The launching application "/<path>/<to>/Project1.app" does not exist or is not executable.
See Run -> Run Paramaters -> local
Steps To ReproduceStart a new project (File -> New -> Application),
Save all (if the IDE will let you!) in a project folder.
In Project Options, create an Application bundle.
Run this application (click "Run without debugging").
Additional Information- All settings in "Run -> Run Paramaters -> local" are default (blank).
- The project1.app application bundle exists.
- The file "project1.app/Content/MacOS/project1" links to the executable.
- Running Project1.app straight from Finder works just fine.
- Running the linked file from Finder works just fine.
- Running the binary from Finder works as well.

Note 1 - WITH debugger works:
When running WITH debugger, even though it takes a very long time to start, does work properly. I'm using GDB 4.3 that came with the last XCode that came with GDB.

Note 2 - Setting debugger to NONE works:
When using the normal "run" button (with debugger), but setting DEBUGGER to "NONE" (Tools -> options -> Debugger -> Debugger Type = none), the application DOES work properly without debugger.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCarbon
Attached Files

Relationships

duplicate of 0031597 resolvedMattias Gaertner Patches Mac app-bundle cannot run w/out debugging 

Activities

Hans Luijten

2016-08-20 13:40

reporter  

invalid-application.jpg (21,832 bytes)
invalid-application.jpg (21,832 bytes)

Cyrax

2016-08-20 16:32

reporter   ~0094218

Upgrade your GDB version.

See this wiki link how to accomplish that http://wiki.lazarus.freepascal.org/GDB_on_OS_X_Mavericks_or_newer_and_Xcode_5_or_newer

Hans Luijten

2016-08-20 17:39

reporter   ~0094219

I'm confused :-)
Just to clarify (apologies) ...

Click "Run":
Debugger set to GDB: it works correctly.
Debugger set to None: it works correctly.

Click "Run without debugging"
Debugger set to None: it works correctly.
Debugger set to GDB: it fails....
 
Is it a parameter passed to the debugger to not debug?
Maybe I looked at it too simple that "Run without debugging" would simply (temporary) set the debugger to "none"?

Cyrax

2016-08-20 18:09

reporter   ~0094221

Oh, my! I was too hasty during reading your report! Sorry! :)

You should ask in the forum and in the mailing lists, too.

Juha Manninen

2016-08-20 18:14

developer   ~0094222

You should ask confirmation from others for all your Carbon issues. I have understood that many people use Carbon but nobody complained about such issues.

Hans Luijten

2016-08-20 19:44

reporter   ~0094224

Last edited: 2016-08-20 19:45

View 2 revisions

Thank Juha and no worries Cyrax :-)

I've posted it in the forum as well (http://forum.lazarus.freepascal.org/index.php/topic,33769.0.html), but I'm not sure how many folks will respond or not. I've asked for confirmation before, with other issues, and it seems very few Mac users respond. :-(

If I could compile the IDE in Cocoa then that would have been nicer ;-)

Hans Luijten

2016-08-20 19:46

reporter   ~0094225

Forgot to mention that I'm not using the mailinglist :-(

CudaText man

2017-04-30 15:00

reporter   ~0100007

Dupl;
fixed in the meantime.

Juha Manninen

2017-04-30 15:57

developer   ~0100013

Is there a duplicate report?

CudaText man

2017-04-30 16:21

reporter   ~0100014

Dupl http://mantis.freepascal.org/view.php?id=31597

Juha Manninen

2017-04-30 16:25

developer   ~0100015

Resolving.

Hans Luijten

2018-01-17 19:02

reporter   ~0105889

Seems resolved in SVN.

Issue History

Date Modified Username Field Change
2016-08-20 13:40 Hans Luijten New Issue
2016-08-20 13:40 Hans Luijten File Added: invalid-application.jpg
2016-08-20 16:32 Cyrax Note Added: 0094218
2016-08-20 17:39 Hans Luijten Note Added: 0094219
2016-08-20 18:09 Cyrax Note Added: 0094221
2016-08-20 18:14 Juha Manninen Note Added: 0094222
2016-08-20 19:44 Hans Luijten Note Added: 0094224
2016-08-20 19:45 Hans Luijten Note Edited: 0094224 View Revisions
2016-08-20 19:46 Hans Luijten Note Added: 0094225
2017-04-30 15:00 CudaText man Note Added: 0100007
2017-04-30 15:57 Juha Manninen Note Added: 0100013
2017-04-30 16:21 CudaText man Note Added: 0100014
2017-04-30 16:25 Juha Manninen LazTarget => -
2017-04-30 16:25 Juha Manninen Note Added: 0100015
2017-04-30 16:25 Juha Manninen Relationship added duplicate of 0031597
2017-04-30 16:25 Juha Manninen Status new => resolved
2017-04-30 16:25 Juha Manninen Resolution open => duplicate
2017-04-30 16:25 Juha Manninen Assigned To => Juha Manninen
2018-01-17 19:02 Hans Luijten Note Added: 0105889
2018-01-17 19:02 Hans Luijten Status resolved => closed