View Issue Details

IDProjectCategoryView StatusLast Update
0030491LazarusIDEpublic2019-12-12 12:50
ReporterHans Luijten Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
PlatformCarbonOSMacOS X 
Product Version1.7 (SVN) 
Summary0030491: IDE: Tools -> Options: Filter non-functional
DescriptionWhen trying to filter settings under Tools-Options, the filter can be clicked, the text "(filter)" disappears, but one cannot type anything there.
Steps To ReproduceOpen the menu Tools -> Options.
Click in the filter field (upper left corner).
Try to type something.
Additional InformationThis might not be specific for this version.
I never used it before, so I have noticed it before.
It does happen in Lazarus 1.6 (release) as well.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCarbon
Attached Files

Activities

Bart Broersma

2016-08-21 00:45

developer   ~0094230

Works OK on Windows (Lazarus 1.7 r52754 FPC 3.0.0 i386-win32-win32/win64).
Maybe widgetset related?

Hans Luijten

2016-08-21 11:39

reporter   ~0094234

Could very well be,... however when I go to: Tools -> Options -> Key Mappings, the filter box (on the right) works just fine.

Now, funny thing happens;
When opening Tools -> Options, I cannot type in the filter box.
However, when I paste text in it, then suddenly it works and I can type. Until I close the window and open it up again, then it doesn't work again.

CudaText man

2016-12-20 15:50

reporter   ~0096952

Filter is working today, trunk, I see bold items in right, for filter string. Pls close

Juha Manninen

2016-12-20 19:24

developer   ~0096961

Hans, can you still reproduce?

Hans Luijten

2016-12-21 03:44

reporter  

failing-filter.jpg (100,978 bytes)   
failing-filter.jpg (100,978 bytes)   

Hans Luijten

2016-12-21 03:47

reporter   ~0096977

Just updated to SVN 53744, OSX 10.12), and the filter is still not responding to keystrokes.
I can select the filter, the "(filter)" text disappears, but I cannot type anything ...

(see also the screenshot I've uploaded)

AlexeyT; since you mention the object inspector checkbox issue to be fixed: which version are you using? I'd be happy to test ...

CudaText man

2016-12-21 03:57

reporter   ~0096980

Ops, test was on Ubuntu. I repeat bug on OSX 10.8. Filter in dlg don't get input keys, rt-click menu dont appear.

Juha Manninen

2016-12-23 14:45

developer   ~0097037

I don't have a Mac. Detaching myself.

Juha Manninen

2019-12-11 18:51

developer   ~0119758

Last edited: 2019-12-11 19:04

View 2 revisions

Does this work with LCL-Cocoa?

The control is a standard TTreeFilterEdit from LazControls. I wonder why it does not work with Carbon. Does it work when you put it into your own application?

Hans Luijten

2019-12-12 11:27

reporter   ~0119778

Yes it works in Cocoa just fine.
As far as I'm concerned, since Carbon is no longer used by Apple (correct me if I'm wrong), we can close this ticket (I can't close it).
I no longer use Carbon and can't run 32bit apps anymore (running Catalina which will not run 32bit).

On that note, and maybe this should be a separate bug report (?), the "Tools" - "Options" menu on Mac has been moved to "Lazarus" - "Preferences".
Maybe a good idea to keep it under "Tools" - "Options" as well, since pretty much any description related to Lazarus uses that, so a user may keep searching for it and can't find it ... since now it's in a different menu and called "Preferences". (I'm used to Tools-Options as well, so every single time I look in theqwrong spot)

Juha Manninen

2019-12-12 12:47

developer   ~0119786

Ok, resolving as "won't fix".
Ask questions about "Lazarus" - "Preferences" menu item in forum or mailing list. I believe there was a reason for moving it but I don't know details. No Mac here.

Issue History

Date Modified Username Field Change
2016-08-20 15:37 Hans Luijten New Issue
2016-08-21 00:45 Bart Broersma Note Added: 0094230
2016-08-21 11:39 Hans Luijten Note Added: 0094234
2016-12-20 15:50 CudaText man Note Added: 0096952
2016-12-20 19:24 Juha Manninen LazTarget => -
2016-12-20 19:24 Juha Manninen Note Added: 0096961
2016-12-20 19:24 Juha Manninen Assigned To => Juha Manninen
2016-12-20 19:24 Juha Manninen Status new => feedback
2016-12-21 03:44 Hans Luijten File Added: failing-filter.jpg
2016-12-21 03:47 Hans Luijten Note Added: 0096977
2016-12-21 03:47 Hans Luijten Status feedback => assigned
2016-12-21 03:57 CudaText man Note Added: 0096980
2016-12-23 14:45 Juha Manninen Note Added: 0097037
2016-12-23 14:45 Juha Manninen Assigned To Juha Manninen =>
2016-12-23 14:45 Juha Manninen Status assigned => new
2019-12-11 18:51 Juha Manninen Note Added: 0119758
2019-12-11 19:04 Juha Manninen Note Edited: 0119758 View Revisions
2019-12-12 11:27 Hans Luijten Note Added: 0119778
2019-12-12 12:45 Juha Manninen Assigned To => Juha Manninen
2019-12-12 12:45 Juha Manninen Status new => assigned
2019-12-12 12:47 Juha Manninen Status assigned => resolved
2019-12-12 12:47 Juha Manninen Resolution open => won't fix
2019-12-12 12:47 Juha Manninen Widgetset Carbon => Carbon
2019-12-12 12:47 Juha Manninen Note Added: 0119786
2019-12-12 12:50 Hans Luijten Status resolved => closed