View Issue Details

IDProjectCategoryView StatusLast Update
0030604LazarusPatchpublic2016-11-07 08:18
ReporterPascal RiekenbergAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.7 (SVN)Product Build 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0030604: make FOnMousLink and FOnClickLink protected
DescriptionMake FOnMousLink and FOnClickLink protected to make it
accessible in derived classes.
At the moment it is made public by TSynEdit (properties OnMouseLink and OnClickLink)

With this change i also can publish these properties in classes derived from TCustomSynEdit.
Additional InformationOther solution would be to keep the FOnMouseLink and FOnClickLink private and
intruduce protected properties in TCustomSynEdit. With this i only have to reintroduce them as public properties in classes derived from TCustomSynEdit.
TagsNo tags attached.
Fixed in Revision52974
LazTarget1.8
Widgetset
Attached Files
  • synedit.pp_OnMouseLink_OnClickLink_protected.patch (947 bytes)
    Index: synedit.pp
    ===================================================================
    --- synedit.pp	(revision 52972)
    +++ synedit.pp	(working copy)
    @@ -579,8 +587,6 @@
         fOnSpecialLineColors: TSpecialLineColorsEvent;// needed, because bug fpc 11926
         fOnStatusChange: TStatusChangeEvent;
         FOnSpecialLineMarkup: TSpecialLineMarkupEvent;// needed, because bug fpc 11926
    -    FOnClickLink: TMouseEvent;
    -    FOnMouseLink: TSynMouseLinkEvent;
         FPendingFoldState: String;
     
         procedure AquirePrimarySelection;
    @@ -750,6 +756,8 @@
         procedure InternalBeginUndoBlock(aList: TSynEditUndoList = nil); // includes paintlock
         procedure InternalEndUndoBlock(aList: TSynEditUndoList = nil);
       protected
    +    FOnClickLink: TMouseEvent;
    +    FOnMouseLink: TSynMouseLinkEvent;
         {$IFDEF EnableDoubleBuf}
         BufferBitmap: TBitmap; // the double buffer
         SavedCanvas: TCanvas; // the normal TCustomControl canvas during paint
    

Activities

Pascal Riekenberg

2016-09-15 06:53

reporter  

synedit.pp_OnMouseLink_OnClickLink_protected.patch (947 bytes)
Index: synedit.pp
===================================================================
--- synedit.pp	(revision 52972)
+++ synedit.pp	(working copy)
@@ -579,8 +587,6 @@
     fOnSpecialLineColors: TSpecialLineColorsEvent;// needed, because bug fpc 11926
     fOnStatusChange: TStatusChangeEvent;
     FOnSpecialLineMarkup: TSpecialLineMarkupEvent;// needed, because bug fpc 11926
-    FOnClickLink: TMouseEvent;
-    FOnMouseLink: TSynMouseLinkEvent;
     FPendingFoldState: String;
 
     procedure AquirePrimarySelection;
@@ -750,6 +756,8 @@
     procedure InternalBeginUndoBlock(aList: TSynEditUndoList = nil); // includes paintlock
     procedure InternalEndUndoBlock(aList: TSynEditUndoList = nil);
   protected
+    FOnClickLink: TMouseEvent;
+    FOnMouseLink: TSynMouseLinkEvent;
     {$IFDEF EnableDoubleBuf}
     BufferBitmap: TBitmap; // the double buffer
     SavedCanvas: TCanvas; // the normal TCustomControl canvas during paint

Issue History

Date Modified Username Field Change
2016-09-15 06:53 Pascal Riekenberg New Issue
2016-09-15 06:53 Pascal Riekenberg File Added: synedit.pp_OnMouseLink_OnClickLink_protected.patch
2016-09-15 12:12 Martin Friebe Assigned To => Martin Friebe
2016-09-15 12:12 Martin Friebe Status new => assigned
2016-09-15 12:49 Martin Friebe Fixed in Revision => 52974
2016-09-15 12:49 Martin Friebe LazTarget => 1.8
2016-09-15 12:49 Martin Friebe Status assigned => resolved
2016-09-15 12:49 Martin Friebe Fixed in Version => 1.7 (SVN)
2016-09-15 12:49 Martin Friebe Resolution open => fixed
2016-09-15 12:49 Martin Friebe Target Version => 1.8
2016-11-07 08:18 Pascal Riekenberg Status resolved => closed