View Issue Details

IDProjectCategoryView StatusLast Update
0030684LazarusIDEpublic2016-10-20 16:36
ReporteraccorpAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindows 7, Ubuntu 14.04OS Version
Product Version1.6.1 (SVN)Product Build53067 
Target Version1.6.2Fixed in Version1.7 (SVN) 
Summary0030684: Editor exception on paster-then-undo text with compiler directive
DescriptionPasting "{$if}<space><new_line>" (or any other valid directive) and then undoing last operation cause unhandled exception in the editor.

"Invalid argument index in format "Line=%d NType=%s State=%s OpenState=%s Flags=%s StartCol=%d EndCol=%d"."
Steps To ReproduceCopy next two lines to the clipboard:

{$if} 
preserve_newline


Put text cursor on the empty line and paste text from the clipboard. Undo last operation with Ctrl+Z or via menu.
TagsNo tags attached.
Fixed in Revision53133
LazTarget1.6.2
WidgetsetGTK 2, Win32/Win64
Attached Files

Activities

accorp

2016-10-03 03:35

reporter  

ubuntu.png (22,178 bytes)
ubuntu.png (22,178 bytes)

wp

2016-10-03 10:11

developer   ~0094936

I can confirm on Laz trunk / Win 10.

Martin Friebe

2016-10-17 04:28

manager   ~0095195

The problem was caused by a bug in the trailing spaces trimmer.

Fixed, please test and close if ok

accorp

2016-10-20 16:35

reporter   ~0095236

It works, thank you.

Issue History

Date Modified Username Field Change
2016-10-03 03:31 accorp New Issue
2016-10-03 03:35 accorp File Added: ubuntu.png
2016-10-03 10:11 wp Note Added: 0094936
2016-10-03 13:39 Martin Friebe Assigned To => Martin Friebe
2016-10-03 13:39 Martin Friebe Status new => assigned
2016-10-17 04:28 Martin Friebe Fixed in Revision => 53133
2016-10-17 04:28 Martin Friebe LazTarget => 1.6.2
2016-10-17 04:28 Martin Friebe Note Added: 0095195
2016-10-17 04:28 Martin Friebe Status assigned => resolved
2016-10-17 04:28 Martin Friebe Fixed in Version => 1.7 (SVN)
2016-10-17 04:28 Martin Friebe Resolution open => fixed
2016-10-17 04:28 Martin Friebe Target Version => 1.6.2
2016-10-20 16:35 accorp Note Added: 0095236
2016-10-20 16:36 accorp Status resolved => closed