View Issue Details

IDProjectCategoryView StatusLast Update
0030791FPCCompilerpublic2019-10-09 13:48
ReporterBoris GlavinAssigned ToJoost van der Sluis 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSUbuntuOS Version16.04
Product Version3.1.1Product Build 
Target VersionFixed in Version 
Summary0030791: Option at position 26 (-sp) needs an argument
Descriptionmake crossinstall FPMAKEOPT="-v" NOGDB=1 CPU_TARGET=i386
in path "ide"
./fpmake compile -v --localunitdir=.. --globalunitdir=../packages --os=linux --cpu=i386 -o -Pi386 -o -XPi386-linux- -o -Xr -o -Ur -o -Xs -o -O2 -o -n -o -dRELEASE --compiler=/tmp/fpc/compiler/ppcross386 -bu --NoGDB=1 -sp
Warning: Better do not combine the SearchPath and Global/Local-UnitDir parameters
The installer encountered the following error:
Option at position 26 (-sp) needs an argument
Additional InformationWork with:
NOGDB=0
or path
Index: ide/Makefile
===================================================================
--- ide/Makefile (revision 34765)
+++ ide/Makefile (working copy)
@@ -2304,7 +2304,7 @@
 endif # NOGDB
 ifndef GDBMI_IS_STATIC
 ifndef BUILDFULLNATIVE
-FPMAKE_OPT+=-sp
+FPMAKE_OPT+=--skipcrossprograms
 endif
 endif # GDBMI_IS_STATIC
 ifdef PPC_TARGET
Index: ide/Makefile.fpc
===================================================================
--- ide/Makefile.fpc (revision 34765)
+++ ide/Makefile.fpc (working copy)
@@ -73,7 +73,7 @@
 ifndef GDBMI_IS_STATIC
 ifndef BUILDFULLNATIVE
 # Omit executable is only required if generated executable is not static
-FPMAKE_OPT+=-sp
+FPMAKE_OPT+=--skipcrossprograms
 endif
 endif # GDBMI_IS_STATIC
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Max Nazhalov

2016-10-26 13:42

reporter   ~0095335

I've encountered similar issue a few weeks ago.
Native Win32 build from a clean directory succeed, and after that crossbuilding compiler for some other targets (e.g. msdos) with
make ... clean all crossinstall
(i.e. without distclean) fail early with exactly the same error: "Option at position ... (-sp) needs an argument".

make distclean from the src root before cross-building resolve the problem for me.

Reproduced build logs [r34703] attached.

Max Nazhalov

2016-10-26 13:42

reporter  

weired-sp logs.zip (47,262 bytes)

Boris Glavin

2018-01-13 22:00

reporter   ~0105756

After removal the IDE question has lost relevance

Marco van de Voort

2018-02-10 15:09

manager   ~0106317

IDE was not removed, but moved to packages/ide. But you can't reproduce the problem anymore?

Marco van de Voort

2018-02-22 13:50

manager   ~0106533

Checked some more. 3.0.x fpmake still supports -sp, and the options is gone from 3.1.1 it seems. -> close

Issue History

Date Modified Username Field Change
2016-10-26 09:04 Boris Glavin New Issue
2016-10-26 13:42 Max Nazhalov Note Added: 0095335
2016-10-26 13:42 Max Nazhalov File Added: weired-sp logs.zip
2016-11-01 13:35 Jonas Maebe Assigned To => Joost van der Sluis
2016-11-01 13:35 Jonas Maebe Status new => assigned
2018-01-13 22:00 Boris Glavin Note Added: 0105756
2018-02-10 15:09 Marco van de Voort Note Added: 0106317
2018-02-22 13:50 Marco van de Voort Note Added: 0106533
2018-02-22 13:50 Marco van de Voort Status assigned => resolved
2018-02-22 13:50 Marco van de Voort Resolution open => no change required