View Issue Details

IDProjectCategoryView StatusLast Update
0030849LazarusIDEpublic2016-11-03 08:09
ReporterMario Bonati Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformWindowsOSWindows 10 
Product Version1.7 (SVN) 
Summary0030849: TCheckListBox haven't CheckBox
DescriptionHi,
on Windows, on the TCheckListBox, only if Style = lbStandard there is the CheckBox.
If Style is lbOwnerDrawFixed, lbOwnerDrawVariable, or lbVirtual, CheckBox is not visible, there is only the text.
On Linux, it works Ok for all 4 Styles.

Thanks in advance, Mario
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0029525 new TCheckListBox dos not act like I expect. Check boxes are missing. 

Activities

Michl

2016-11-02 20:26

developer   ~0095496

Last edited: 2016-11-02 20:27

View 2 revisions

Yes, this is a known bug (or not implemented feature), see 0029525.

Mario Bonati

2016-11-02 20:29

reporter   ~0095497

Ok, thanks, Mario

Bart Broersma

2016-11-02 21:08

developer   ~0095498

Please close this one.

Issue History

Date Modified Username Field Change
2016-11-02 19:57 Mario Bonati New Issue
2016-11-02 20:26 Michl Note Added: 0095496
2016-11-02 20:27 Michl Note Edited: 0095496 View Revisions
2016-11-02 20:29 Mario Bonati Note Added: 0095497
2016-11-02 21:08 Bart Broersma LazTarget => -
2016-11-02 21:08 Bart Broersma Note Added: 0095498
2016-11-02 21:08 Bart Broersma Relationship added duplicate of 0029525
2016-11-02 21:08 Bart Broersma Status new => resolved
2016-11-02 21:08 Bart Broersma Resolution open => duplicate
2016-11-02 21:08 Bart Broersma Assigned To => Bart Broersma
2016-11-03 08:09 Mario Bonati Status resolved => closed