View Issue Details

IDProjectCategoryView StatusLast Update
0030910LazarusWidgetsetpublic2020-04-25 12:40
Reporterjosh Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformOSX CarbonOSOSX 
Product Version1.7 (SVN) 
Summary0030910: Scroll Bars always visible on TScrollBox
DescriptionTSCrollbox Scroll Bars always Visible.
Steps To ReproducePlace tscrollbox on a form, set its vertical and horizontal scrollbars to NOT visible;
But the scrollbars are visible in IDE and when compiled.

How to hide the scroll bars ?

TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCarbon
Attached Files

Relationships

duplicate of 0027449 new Scrollbars always visible in scrolling controls 

Activities

Mattias Gaertner

2016-11-11 11:53

manager   ~0095760

Works on Linux/Gtk2. Maybe bug only appears on Carbon.

josh

2016-11-14 10:25

reporter   ~0095860

Works on Windoes too, but not carbon.

TK

2017-01-12 14:09

reporter   ~0097434

It seems that the same bug applies for every control with custom scrollbars. For example TSynEdit (run Lazarus, open new unit and make the source editor taller than the file content. Vertical scrollbar should disappear but stays).
Happens only on OSX/Carbon.

Pavol S

2017-03-18 13:31

reporter   ~0099011

Last edited: 2017-03-18 13:50

View 2 revisions

Under COCOA no scrollbars visible and ScrollBy don't work. So TScrollBar is not working on macOS. Any chance to fix this?

This solution work for me and CARBON: http://bugs.freepascal.org/view.php?id=27449

Juha Manninen

2017-03-18 15:39

developer   ~0099017

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2016-11-11 11:44 josh New Issue
2016-11-11 11:53 Mattias Gaertner Note Added: 0095760
2016-11-14 10:25 josh Note Added: 0095860
2017-01-12 14:09 TK Note Added: 0097434
2017-03-18 13:31 Pavol S Note Added: 0099011
2017-03-18 13:50 Pavol S Note Edited: 0099011 View Revisions
2017-03-18 15:38 Juha Manninen Relationship added duplicate of 0027449
2017-03-18 15:39 Juha Manninen LazTarget => -
2017-03-18 15:39 Juha Manninen Note Added: 0099017
2017-03-18 15:39 Juha Manninen Status new => resolved
2017-03-18 15:39 Juha Manninen Resolution open => duplicate
2017-03-18 15:39 Juha Manninen Assigned To => Juha Manninen