View Issue Details

IDProjectCategoryView StatusLast Update
0030913LazarusLCLpublic2016-12-19 15:18
ReporterJanusz TomczakAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindowsOS Version7
Product Version1.7 (SVN)Product Build 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0030913: texthint bug
DescriptionTextHint bug, when programmatically assign edit.text
Steps To Reproduce- edit1.texthint:='search'
- edit1.text:='test'
- edit1 text is not set, changed texthint

Please see the attached demo program.
Additional InformationProbably started in revision 53296
TagsNo tags attached.
Fixed in Revisionr53343
LazTarget1.8
WidgetsetWin32/Win64
Attached Files

Activities

Janusz Tomczak

2016-11-11 12:43

reporter  

texthint_bug.zip (129,472 bytes)

Bart Broersma

2016-11-11 13:05

developer   ~0095764

Last edited: 2016-11-11 13:15

View 2 revisions

It's a regression caused by revision 53296 by blikblum.

Bart Broersma

2016-11-11 13:18

developer   ~0095765

Please test and close if OK.

Ondrej Pokorny

2016-11-11 18:06

reporter   ~0095776

As a second regression, please mind also http://lists.lazarus-ide.org/pipermail/lazarus/2016-October/230066.html

Bart Broersma

2016-11-11 22:16

developer   ~0095784

@Ondrej:
1. what has that to do with TextHint?
2. I don't have a mouse, so nomousewheel ....

Ondrej Pokorny

2016-11-11 22:26

reporter   ~0095785

Sorry, I wrote it into wrong issue :( correct one: 0030904

Issue History

Date Modified Username Field Change
2016-11-11 12:43 Janusz Tomczak New Issue
2016-11-11 12:43 Janusz Tomczak File Added: texthint_bug.zip
2016-11-11 13:05 Bart Broersma Note Added: 0095764
2016-11-11 13:10 Bart Broersma Assigned To => Bart Broersma
2016-11-11 13:10 Bart Broersma Status new => assigned
2016-11-11 13:15 Bart Broersma Note Edited: 0095764 View Revisions
2016-11-11 13:18 Bart Broersma Fixed in Revision => r53343
2016-11-11 13:18 Bart Broersma LazTarget => 1.8
2016-11-11 13:18 Bart Broersma Note Added: 0095765
2016-11-11 13:18 Bart Broersma Status assigned => resolved
2016-11-11 13:18 Bart Broersma Fixed in Version => 1.7 (SVN)
2016-11-11 13:18 Bart Broersma Resolution open => fixed
2016-11-11 13:18 Bart Broersma Target Version => 1.8
2016-11-11 18:06 Ondrej Pokorny Note Added: 0095776
2016-11-11 22:16 Bart Broersma Note Added: 0095784
2016-11-11 22:16 Bart Broersma Status resolved => assigned
2016-11-11 22:16 Bart Broersma Resolution fixed => reopened
2016-11-11 22:26 Ondrej Pokorny Note Added: 0095785
2016-11-11 22:26 Ondrej Pokorny Status assigned => resolved
2016-11-11 22:26 Ondrej Pokorny Resolution reopened => fixed
2016-12-19 15:18 Janusz Tomczak Status resolved => closed