View Issue Details

IDProjectCategoryView StatusLast Update
0031008LazarusWidgetsetpublic2016-11-27 12:52
ReporterjoshAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMACOSOSXOS VersionEl Capitan
Product Version1.7 (SVN)Product Build 
Target VersionFixed in Version 
Summary0031008: LAzarus Trunk BROKEN :- Wrong Number of parametsrs specified for CompareText
DescriptionTrying to install Lazarus and FPC Trunk; but when trying to compile codetools; it bombs out with following errors.

I have cleaned out the folder prior to install.

/Users/josh/Lazarus_Trunk/lazarus/components/codetools/fileprocs.pas(1354,12) Error: (3026) Wrong number of parameters specified for call to "CompareText"
/Users/josh/Lazarus_Trunk/fpc/units/i386-darwin/univint/MacOSAll.ppu:StringCompare.pas(376,10) Error: (5088) Found declaration: CompareText(Pointer;Pointer;SmallInt;SmallInt;Handle):SmallInt;
/Users/josh/Lazarus_Trunk/lazarus/components/codetools/fileprocs.pas(1565,15) Error: (3026) Wrong number of parameters specified for call to "CompareText"
/Users/josh/Lazarus_Trunk/fpc/units/i386-darwin/univint/MacOSAll.ppu:StringCompare.pas(376,10) Error: (5088) Found declaration: CompareText(Pointer;Pointer;SmallInt;SmallInt;Handle):SmallInt;
fileprocs.pas(2549) Fatal: (10026) There were 4 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: /Users/josh/Lazarus_Trunk/fpc/bin/i386-darwin/ppc386 returned an error exitcode
Steps To ReproduceDownload and compile lazarus trunk
TagsNo tags attached.
Fixed in Revisionr53468
LazTarget-
WidgetsetCarbon
Attached Files

Activities

Juha Manninen

2016-11-25 14:48

developer   ~0096228

Last edited: 2016-11-25 14:49

View 2 revisions

CompareText is in SysUtils. Why does your compiler not find it there?
Please do a clean build of everything. Usually it helps.
This kind of configuration problems should be asked in mailing list or forum actually.

Juha Manninen

2016-11-26 11:10

developer   ~0096244

I resolve this as it is clearly a local configuration etc. issue.
In future please ask in the forum first before reporting such errors.

josh

2016-11-27 11:10

reporter   ~0096289

Please see forum post
http://forum.lazarus.freepascal.org/index.php/topic,34645.150.html

Juha Manninen

2016-11-27 11:56

developer   ~0096290

Right, it was a valid issue after all. I added the "SysUtils." in front of CompareText.
The best fix could be to move this:
 {$IFnDEF Windows}
 uses
   {$IFDEF darwin}
   MacOSAll,
   {$ENDIF}
   Unix;
 {$ENDIF}
from implementations section to top of interface uses section.
The unit later in the list always takes precedence.

josh

2016-11-27 12:51

reporter   ~0096292

Last edited: 2016-11-27 12:52

View 2 revisions

The SysUtils.comparetext works as in post.

Also adding

 {$IFnDEF Windows}
   {$IFDEF darwin}
     MacOSAll,
   {$ENDIF}
   Unix,
 {$ENDIF}

to the File Procs Uses statement at Line 35, and removing from implementation also works. This is the better option.

Has svn been updated?; so I can test this also.
It takes about 90 minutes for me to download and test of complete trunk ( removing all previous data).

Issue History

Date Modified Username Field Change
2016-11-25 10:27 josh New Issue
2016-11-25 14:48 Juha Manninen Note Added: 0096228
2016-11-25 14:49 Juha Manninen Note Edited: 0096228 View Revisions
2016-11-26 11:10 Juha Manninen LazTarget => -
2016-11-26 11:10 Juha Manninen Note Added: 0096244
2016-11-26 11:10 Juha Manninen Status new => resolved
2016-11-26 11:10 Juha Manninen Resolution open => unable to reproduce
2016-11-26 11:10 Juha Manninen Assigned To => Juha Manninen
2016-11-27 11:10 josh Note Added: 0096289
2016-11-27 11:51 Juha Manninen Status resolved => assigned
2016-11-27 11:51 Juha Manninen Resolution unable to reproduce => reopened
2016-11-27 11:56 Juha Manninen Fixed in Revision => r53468
2016-11-27 11:56 Juha Manninen Note Added: 0096290
2016-11-27 11:56 Juha Manninen Status assigned => resolved
2016-11-27 11:56 Juha Manninen Resolution reopened => fixed
2016-11-27 12:51 josh Note Added: 0096292
2016-11-27 12:52 josh Note Edited: 0096292 View Revisions