View Issue Details

IDProjectCategoryView StatusLast Update
0031078FPCDatabasepublic2016-12-11 17:15
ReporterregsAssigned ToLacaK 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version3.1.1 
Summary0031078: SQLQuery string filed limited to number of bytes rather than symbols with UTF8
DescriptionNon-Latin strings appears to be cut

TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0017376 resolvedLacaK TSQLite3Connection not show whole content for string field when the field is asia language 

Activities

regs

2016-12-06 18:44

reporter  

regs

2016-12-06 18:44

reporter  

LacaK

2016-12-07 21:04

developer   ~0096580

Solution to this problem is prepared in TRUNK
Btw please move to FPC project

Thaddy de Koning

2016-12-08 16:53

reporter   ~0096603

Last edited: 2016-12-08 18:58

View 3 revisions

Is indeed fixed in trunk.
You can do it in 3,0 as well by allocating strings 4 times the size of AnsiString.
That is needed because the maximum code point size in UTF8 is 4 bytes.
So compared to AnsiString it needs to be 4 times as big to cover all scenarios for UTF8.

This is also given on the forum as a temporary solution somewhere.

LacaK

2016-12-11 17:12

developer   ~0096698

There was introduced functionality in FPC TRUNK , which will handle CharacterSize based on connection CharSet and allocate buffers, which will be able to hold whole string size.
Note, that TStringField.Size is size in characters while TString.DataSize is size in bytes.

Issue History

Date Modified Username Field Change
2016-12-06 18:44 regs New Issue
2016-12-06 18:44 regs File Added: 2016-12-06 20-11-58 Lazarus IDE v1.7 - lbhotlighttest.png
2016-12-06 18:44 regs File Added: 2016-12-06 20-15-18 SQLiteStudio (3.1.0) - [doctype (nakl_refs)].png
2016-12-07 21:04 LacaK Note Added: 0096580
2016-12-08 00:16 Maxim Ganetsky Project Packages => FPC
2016-12-08 16:53 Thaddy de Koning Note Added: 0096603
2016-12-08 16:53 Thaddy de Koning Note Edited: 0096603 View Revisions
2016-12-08 18:58 Thaddy de Koning Note Edited: 0096603 View Revisions
2016-12-11 17:10 LacaK Assigned To => LacaK
2016-12-11 17:10 LacaK Status new => assigned
2016-12-11 17:12 LacaK Note Added: 0096698
2016-12-11 17:12 LacaK Status assigned => resolved
2016-12-11 17:12 LacaK Fixed in Version => 3.1.1
2016-12-11 17:12 LacaK Resolution open => fixed
2016-12-11 17:15 LacaK Relationship added related to 0017376