View Issue Details

IDProjectCategoryView StatusLast Update
0031195FPCPackagespublic2017-01-28 17:25
ReporterAndrey ZubarevAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0031195: fcl-passrc fails to parse "Syntax error at token "else""
Descriptionon this code:
function TWin32ThemeServices.ContentRect(DC: HDC; Details: TThemedElementDetails; BoundingRect: TRect): TRect;
begin
  if ThemesEnabled then
    with Details do
      GetThemeBackgroundContentRect(Theme[Element], DC, Part, State, BoundingRect, @Result)
  else
    Result := inherited;
end;
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0030717 resolvedMichael Van Canneyt fcl-passrc fails to parse "else" right after a tricky case with "for" 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-01-05 23:47 Andrey Zubarev New Issue
2017-01-06 08:50 Michael Van Canneyt Assigned To => Michael Van Canneyt
2017-01-06 08:50 Michael Van Canneyt Status new => assigned
2017-01-28 13:26 Michael Van Canneyt Relationship added duplicate of 0030717
2017-01-28 13:26 Michael Van Canneyt Status assigned => resolved
2017-01-28 13:26 Michael Van Canneyt Resolution open => duplicate
2017-01-28 17:25 Andrey Zubarev Status resolved => closed