View Issue Details

IDProjectCategoryView StatusLast Update
0031198FPCRTLpublic2017-07-23 10:57
ReporterJean SUZINEAUAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.0Product Build2015/12/05 
Target Version3.2.0Fixed in Version3.1.1 
Summary0031198: FormatFloat / FloatToTextFmt : Thousand Separator 9999.99 instead of 9,999.99
DescriptionFormatFloat( '#,###,###,###,###.00', 9999.99) produces 9999.99 instead of 9,999.99
Steps To ReproduceI join a test case
Additional InformationTested on Ubuntu 16.04.1 LTS/Lazarus 1.6/FPC 3.0.0 x86_64-linux-gtk 2
and on Windows 10 / Lazarus 1.6RC2/FPC 3.0.0 SVN 51246 x86_64-win64-win32/win64

I join a zip with a test case and a proposition of correction
- Format_Float_test_case: the test case
- Format_Float_Patch: a program with modified version of FloatToTextFmt, and a diff for sysstr.inc

(I hope my diff is correct, I don't use it very often)
TagsNo tags attached.
Fixed in Revision36740
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0029781 closedMichael Van Canneyt Problems DisplayFormat Lazarus 1.6 fpc 3.0 

Activities

Jean SUZINEAU

2017-01-06 14:02

reporter  

FormatFloat.zip (41,737 bytes)

Bart Broersma

2017-01-06 23:04

reporter   ~0097345

Duplicate of 0029781?

Michael Van Canneyt

2017-07-23 10:57

administrator   ~0101863

Indeed duplicate, recently fixed.

Issue History

Date Modified Username Field Change
2017-01-06 14:02 Jean SUZINEAU New Issue
2017-01-06 14:02 Jean SUZINEAU File Added: FormatFloat.zip
2017-01-06 23:04 Bart Broersma Note Added: 0097345
2017-07-23 10:16 Michael Van Canneyt Assigned To => Michael Van Canneyt
2017-07-23 10:16 Michael Van Canneyt Status new => assigned
2017-07-23 10:56 Michael Van Canneyt Relationship added duplicate of 0029781
2017-07-23 10:57 Michael Van Canneyt Fixed in Revision => 36740
2017-07-23 10:57 Michael Van Canneyt Note Added: 0101863
2017-07-23 10:57 Michael Van Canneyt Status assigned => resolved
2017-07-23 10:57 Michael Van Canneyt Fixed in Version => 3.1.1
2017-07-23 10:57 Michael Van Canneyt Resolution open => fixed
2017-07-23 10:57 Michael Van Canneyt Target Version => 3.2.0