View Issue Details

IDProjectCategoryView StatusLast Update
0031210FPCCompilerpublic2017-01-10 19:06
ReporterAlfredAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx86_64OSWindowsOS Version10
Product Version3.1.1Product Buildtrunk latest 
Target VersionFixed in Version 
Summary0031210: Internal error 2015030501 when building cross-compiler
DescriptionWhen trying to build a cross-compiler from Windows 10 with FPC 64bit towards any Linux 64 bit system, an internal error 2015030501 is generated.

Doing the same with FPC 32bit trunk runs 100%.
Doing the same with FPC 64bit fixes runs 100%.
Additional InformationCompiler output:
C:/fpc64/fpcsrc/compiler/ppcrossx64.exe -Ur -Tlinux -XPx86_64-linux- -Xr -Ur -Xs -O2 -n -Fi../inc -Fi../x86_64 -Fi../unix -Fix86_64 -FDC:\fpc64\cross\bin\x86_64-linux -FE. -FUC:/fpc64/fpcsrc/rtl/units/x86_64-linux -Cg -vi-n-h- -dx86_64 -dRELEASE -XPx86_64-linux- -Xd -FlC:\fpc64\cross\lib\x86_64-linux -Us -Sg system.pp
system.pp(393,4) Fatal: Internal error 2015030501
Fatal: Compilation aborted
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0009262 acknowledged No support for 80 bit softfloat in the compiler (needed for non-x86 to x86 crosscompiling) 

Activities

Jonas Maebe

2017-01-10 18:53

manager   ~0097400

Win64 doesn't support the extended type either.

Alfred

2017-01-10 19:06

reporter   ~0097401

Sorry about the duplicate.

Issue History

Date Modified Username Field Change
2017-01-10 13:05 Alfred New Issue
2017-01-10 18:53 Jonas Maebe Note Added: 0097400
2017-01-10 18:53 Jonas Maebe Relationship added duplicate of 0009262
2017-01-10 18:53 Jonas Maebe Status new => resolved
2017-01-10 18:53 Jonas Maebe Resolution open => duplicate
2017-01-10 18:53 Jonas Maebe Assigned To => Jonas Maebe
2017-01-10 19:06 Alfred Note Added: 0097401
2017-01-10 19:06 Alfred Status resolved => closed