View Issue Details

IDProjectCategoryView StatusLast Update
0031235FPCDocumentationpublic2017-01-25 23:01
ReporterLars(L505)Assigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionProduct Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0031235: fmShareDenyWrite docs outdated?
DescriptionIn the documentation on this page:
http://www.freepascal.org/docs-html/rtl/sysutils/fmsharedenywrite.html

The declaration is:
const fmShareDenyWrite = $0020;

However the documentation description refers to it as:
fmOpenShareWrite

Was fmOpenShareWrite the old name for this const and the docs are outdated describing an older name? Should the description be changed to the following text? :

*fmShareDenyWrite* is used in the FileOpen call OR-ed together with one of fmOpenReadWrite, fmOpenRead or fmOpenWrite, to open a file so other processes cannot write to it, they can only read.

(change noted in *asterisks*)
TagsNo tags attached.
Fixed in Revision1379
FPCOldBugId
FPCTarget
Attached Files

Activities

Lars(L505)

2017-01-16 04:16

reporter   ~0097516

Also these docs may be outdated:

http://www.freepascal.org/docs-html/rtl/sysutils/fmshareexclusive.html

Declaration:
const fmShareExclusive = $0010;

Description:

fmOpenShareExclusive is used in the FileOpen call OR-ed together with one of fmOpenReadWrite, fmOpenRead or fmOpenWrite, to open a file exclusively.
See also

Description does not match declartion.. change fmOpenShareExclusive --> fmShareExclusive ?

Lars(L505)

2017-01-16 04:18

reporter   ~0097517

And this page ;-)

http://www.freepascal.org/docs-html/rtl/sysutils/fmsharedenyread.html

And this:
http://www.freepascal.org/docs-html/rtl/sysutils/fmsharecompat.html

Could be more pages... just looks like some old orphaned references that had their const names changed in the source file.

Lars(L505)

2017-01-16 04:21

reporter   ~0097518

On this page it says "modus":

http://www.freepascal.org/docs-html/rtl/sysutils/fmsharecompat.html

Methinks a dutch person wrote it ;-)

Can it be changed to "mode" for naive (and inferior) English programmers like myself..

Thaddy de Koning

2017-01-16 11:23

reporter   ~0097520

Last edited: 2017-01-16 11:30

View 4 revisions

Modus is Latin (and valid in e.g. English, German and Dutch too as loanwords), not Dutch only. The proper Dutch word is "wijze" , the native English is indeed "mode" f.a.i.c.

https://en.wiktionary.org/wiki/modus

Michael Van Canneyt

2017-01-25 23:01

administrator   ~0097710

It was a typo, fixed.

Thanks for reporting!

Issue History

Date Modified Username Field Change
2017-01-16 04:15 Lars(L505) New Issue
2017-01-16 04:15 Lars(L505) Status new => assigned
2017-01-16 04:15 Lars(L505) Assigned To => Michael Van Canneyt
2017-01-16 04:16 Lars(L505) Note Added: 0097516
2017-01-16 04:18 Lars(L505) Note Added: 0097517
2017-01-16 04:21 Lars(L505) Note Added: 0097518
2017-01-16 11:23 Thaddy de Koning Note Added: 0097520
2017-01-16 11:24 Thaddy de Koning Note Edited: 0097520 View Revisions
2017-01-16 11:25 Thaddy de Koning Note Edited: 0097520 View Revisions
2017-01-16 11:30 Thaddy de Koning Note Edited: 0097520 View Revisions
2017-01-25 23:01 Michael Van Canneyt Fixed in Revision => 1379
2017-01-25 23:01 Michael Van Canneyt Note Added: 0097710
2017-01-25 23:01 Michael Van Canneyt Status assigned => resolved
2017-01-25 23:01 Michael Van Canneyt Fixed in Version => 3.1.1
2017-01-25 23:01 Michael Van Canneyt Resolution open => fixed
2017-01-25 23:01 Michael Van Canneyt Target Version => 3.2.0