View Issue Details

IDProjectCategoryView StatusLast Update
0031288LazarusLCLpublic2017-10-20 02:36
ReporterstockiAssigned Towp 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version1.6.3 (SVN)Product Build 
Target VersionFixed in Version 
Summary0031288: Lazarus LCL Win32 does not run W2k
DescriptionLazarus LCL Win32 does not run W2k. Trunk FPC and Laz from today. Got message "PrintWindows not found in user32.dll"
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0025448 closedMichl GetFormImage supplies black Bitmap 

Activities

wp

2017-01-29 11:02

developer   ~0097771

Confusing: why do you specify "product version 1.6.3", but write "Trunk fpc and laz from today"? Which version is affected?

stocki

2017-01-29 11:35

reporter   ~0097772

Sorry I thought it is the latest one. The trunk is affected.

jamie philbrook

2017-01-29 14:37

reporter   ~0097780

Last edited: 2017-01-29 15:05

View 2 revisions

Yes, please fix that because I still use Laz on a W2k machine and I also
have apps that runs on W2K machines in a industrial environment. I have not
yet installed the latest Laz version in my W2K work machine but this will be
a problem.

 Maybe we should be loading that function as needed, doing checks of availability and using alternate methods.

 Please do not use functions that were only brought out for specific desktops.

EDIT:
 I just moved an app over using 1.6.0 Win32 to my W2K machine, it works ok.
So it must be between .2 to .3, I do have 1.6.2 64bit installed here but I obviously can not test with that.

wp

2017-01-29 22:04

developer   ~0097796

Last edited: 2017-01-29 22:54

View 2 revisions

I just installed Laz trunk + fpc trunk on a VM with Win2000. No problems. So, please be more specific: What EXACTLY are you doing when the error is happening?

José Mejuto

2017-01-30 00:24

reporter   ~0097801

Maybe related to this bug ? http://bugs.freepascal.org/view.php?id=25448

Michl

2017-01-30 07:49

developer   ~0097803

Please try with revision 54033, if it works for you too?

wp

2017-01-30 08:55

developer   ~0097807

I used r53477 (pretty old) - no problem for me. But I still don't know what the OP is doing.

Michl

2017-01-30 09:03

developer   ~0097808

Last edited: 2017-01-30 09:22

View 6 revisions

IMHO after r53791, try something like:

procedure TForm1.Button1Click(Sender: TObject);
var
  Bitmap : TBitmap;
begin
  Bitmap := GetFormImage;
  Bitmap.SaveToFile(GetCurrentDir + PathDelim + 'test1.bmp');
  Bitmap.Free;
end;

But yes, a answer from the OP would be nice!

wp

2017-10-09 11:40

developer   ~0103275

Resolving, no feedback.

Issue History

Date Modified Username Field Change
2017-01-29 09:58 stocki New Issue
2017-01-29 11:02 wp Note Added: 0097771
2017-01-29 11:35 stocki Note Added: 0097772
2017-01-29 14:37 jamie philbrook Note Added: 0097780
2017-01-29 15:05 jamie philbrook Note Edited: 0097780 View Revisions
2017-01-29 22:02 wp Assigned To => wp
2017-01-29 22:02 wp Status new => assigned
2017-01-29 22:04 wp Note Added: 0097796
2017-01-29 22:54 wp Note Edited: 0097796 View Revisions
2017-01-30 00:24 José Mejuto Note Added: 0097801
2017-01-30 07:24 Michl Relationship added related to 0025448
2017-01-30 07:49 Michl LazTarget => -
2017-01-30 07:49 Michl Note Added: 0097803
2017-01-30 07:49 Michl Status assigned => feedback
2017-01-30 08:55 wp Note Added: 0097807
2017-01-30 09:03 Michl Note Added: 0097808
2017-01-30 09:04 Michl Note Edited: 0097808 View Revisions
2017-01-30 09:05 Michl Note Edited: 0097808 View Revisions
2017-01-30 09:07 Michl Note Edited: 0097808 View Revisions
2017-01-30 09:07 Michl Note Edited: 0097808 View Revisions
2017-01-30 09:22 Michl Note Edited: 0097808 View Revisions
2017-10-09 11:40 wp Note Added: 0103275
2017-10-09 11:40 wp Status feedback => resolved
2017-10-09 11:40 wp Resolution open => unable to reproduce
2017-10-20 02:36 stocki Status resolved => closed