View Issue Details

IDProjectCategoryView StatusLast Update
0031420FPCDocumentationpublic2017-02-22 20:00
ReporterThaddy de KoningAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformallOSallOS Versionall
Product Version3.1.1Product Build 
Target Version3.2.0Fixed in Version3.0.2 
Summary0031420: Packrecords Alignment:The default alignment (which can be selected with DEFAULT) is natural alignment, contrary to Turbo Pascal,
DescriptionSection 1.2.60
" contrary to Turbo Pascal, where it is 1"
Should be removed because it only the case for TP 1-3 and not for TP 4-7.
The latter have already the packed records, and alignment depends on "Options|Align Data" which can be either 1 or 2,
I don't think it is harmful to remove instead of elaborating on it.
But it is not correct to leave as-is.
Additional InformationIt still creeps up... ;)
TagsNo tags attached.
Fixed in Revision1395
FPCOldBugId
FPCTarget
Attached Files

Activities

Thaddy de Koning

2017-02-20 10:11

reporter   ~0098328

Last edited: 2017-02-20 10:17

View 2 revisions

It is also wrong because 8 bit processors and 8 bit bus processors were supported by TP 1.0 and those have a natural alignment of 1. So "contrary" is wrong anyway.

Michael Van Canneyt

2017-02-22 20:00

administrator   ~0098378

Removed the reference to TP.

Issue History

Date Modified Username Field Change
2017-02-20 10:09 Thaddy de Koning New Issue
2017-02-20 10:09 Thaddy de Koning Status new => assigned
2017-02-20 10:09 Thaddy de Koning Assigned To => Michael Van Canneyt
2017-02-20 10:11 Thaddy de Koning Note Added: 0098328
2017-02-20 10:17 Thaddy de Koning Note Edited: 0098328 View Revisions
2017-02-22 20:00 Michael Van Canneyt Fixed in Revision => 1395
2017-02-22 20:00 Michael Van Canneyt Note Added: 0098378
2017-02-22 20:00 Michael Van Canneyt Status assigned => resolved
2017-02-22 20:00 Michael Van Canneyt Fixed in Version => 3.0.2
2017-02-22 20:00 Michael Van Canneyt Resolution open => fixed
2017-02-22 20:00 Michael Van Canneyt Target Version => 3.2.0