View Issue Details

IDProjectCategoryView StatusLast Update
0031448FPCDocumentationpublic2017-03-04 15:19
ReporterThaddy de KoningAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformallOSallOS Versionall
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0031448: "mm" vs "nn" not sufficiently documented vs preceding "hh"
Descriptionhttp://www.freepascal.org/docs-html/rtl/sysutils/formatchars.html

If any number of "m"'s are used with a preceding number of "h"'s it is interpreted as minutes instead of months, as opposed to "n"'s. This behavior is not documented.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0031449 closedMichael Van Canneyt Incomplete documentation of FormatDateTime 

Activities

Thaddy de Koning

2017-02-27 11:12

reporter   ~0098489

hh:mm:ss

Michael Van Canneyt

2017-03-04 15:19

administrator   ~0098627

Duplicate, other bug fixed.

Issue History

Date Modified Username Field Change
2017-02-27 11:11 Thaddy de Koning New Issue
2017-02-27 11:11 Thaddy de Koning Status new => assigned
2017-02-27 11:11 Thaddy de Koning Assigned To => Michael Van Canneyt
2017-02-27 11:12 Thaddy de Koning Note Added: 0098489
2017-03-04 15:19 Michael Van Canneyt Note Added: 0098627
2017-03-04 15:19 Michael Van Canneyt Relationship added duplicate of 0031449
2017-03-04 15:19 Michael Van Canneyt Status assigned => resolved
2017-03-04 15:19 Michael Van Canneyt Resolution open => duplicate