View Issue Details

IDProjectCategoryView StatusLast Update
0031530FPCLCLpublic2017-03-15 15:34
ReporterFrank De prinsAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWindows 10 64 bitOSOS Version
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0031530: Painting issue in DBGrid
DescriptionGrid contents are repainted incorrectly
Steps To Reproduce- Run the attached application (the database file should be in the same folder as the executable)
- Resize the form by pulling down the bottom window edge
- Grid contents repaint OK
- Resize the form back to it's minimal height
- Now select another row than the first, originally selected one
- Make the form higher again by pulling down the bottom window edge
- Now the grid contents do not paint OK: the lower row(s) is/are painted multiple times.
Additional InformationExecutable, test database and sources attached
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0031532 resolvedMichael Van Canneyt Painting issue in DBGrid 

Activities

Frank De prins

2017-03-13 09:18

reporter  

DBGridIssue.7z (888,063 bytes)

Thaddy de Koning

2017-03-13 09:31

reporter   ~0098862

This is a Lazarus issue, not FPC.

Frank De prins

2017-03-13 09:50

reporter   ~0098863

Should I re-enter it or can I edit this one? (This is the first time I book an issue)

Bart Broersma

2017-03-13 12:20

reporter   ~0098873

Last edited: 2017-03-13 12:23

View 2 revisions

Without waiting for an answere he already opened a new ticket in Lazarus.
Can some devel resolve this as duplicate of 0031532 and then close?

Ondrej Pokorny

2017-03-13 13:35

developer   ~0098880

> @Thaddy: This is a Lazarus issue, not FPC.

Why do you think so?

---

It's a regression and it happened when switching from FPC 2.6 to 3.0:

Lazarus trunk + FPC trunk: BUG
Lazarus trunk + FPC 3.0.0: BUG
Lazarus trunk + FPC 2.6.4: works fine

So it's an FPC bug or Lazarus sources have to be fixed for FPC 3.0.0 changes.

Issue History

Date Modified Username Field Change
2017-03-13 09:18 Frank De prins New Issue
2017-03-13 09:18 Frank De prins File Added: DBGridIssue.7z
2017-03-13 09:31 Thaddy de Koning Note Added: 0098862
2017-03-13 09:50 Frank De prins Note Added: 0098863
2017-03-13 12:20 Bart Broersma Note Added: 0098873
2017-03-13 12:23 Bart Broersma Note Edited: 0098873 View Revisions
2017-03-13 12:23 Bart Broersma Relationship added duplicate of 0031532
2017-03-13 13:35 Ondrej Pokorny Note Added: 0098880
2017-03-15 15:34 Michael Van Canneyt Status new => resolved
2017-03-15 15:34 Michael Van Canneyt Resolution open => duplicate
2017-03-15 15:34 Michael Van Canneyt Assigned To => Michael Van Canneyt