View Issue Details

IDProjectCategoryView StatusLast Update
0031563FPCFCLpublic2017-03-19 11:57
ReporterAndrey ZubarevAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionProduct Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0031563: fcl-passrc: nested comments not handled
Descriptionprogram test111;
begin
 (*
 DebugLn('WARNING: QEventActivationChange(*TRUE*) ',GetWindowManager,' wm strange position: ',Format('X11 x %d y %d Qt x %d y %d',[R.Left, R.Top, QWidget_x(Widget), QWidget_y(Widget)]));
 *)
end.

Gives Parser error: "string exceeds end of line" line:4 column:186 file:E:\zcad\other\pudgb\passrcerrors.pas
TagsNo tags attached.
Fixed in Revision35625
FPCOldBugId
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2017-03-19 10:46

administrator   ~0099050

Fixed. Thanks for reporting!

Out of interest: are you simply test-driving fcl-passrc, or do you have some purpose with all this ?

Andrey Zubarev

2017-03-19 11:57

reporter   ~0099057

Yes, I have a purpose. even a few))

I plan to use fcl-passrc in the small scripting language in my project http://forum.lazarus.freepascal.org/index.php/topic,16665.0.html

I use fcl-passrc in small program http://forum.lazarus.freepascal.org/index.php/topic,34040.msg222027.html#msg222027 because of this I was able to get rid of all circular dependencies in zcad, there were many, and they were a big problem. Much of issues was due zcad sources parsing

Now fcl-passrc parse my sources without problem, I "simply test-driving" in lazarus\lcl\*.pas;*.pp , lazarus\ide\*.pas;*.pp , fpc\ide\*.pas;*.pp , fpc\compiler\*.pas;*.pp etc...

Thank you for your great support!

Issue History

Date Modified Username Field Change
2017-03-19 02:06 Andrey Zubarev New Issue
2017-03-19 10:16 Michael Van Canneyt Assigned To => Michael Van Canneyt
2017-03-19 10:16 Michael Van Canneyt Status new => assigned
2017-03-19 10:46 Michael Van Canneyt Fixed in Revision => 35625
2017-03-19 10:46 Michael Van Canneyt Note Added: 0099050
2017-03-19 10:46 Michael Van Canneyt Status assigned => resolved
2017-03-19 10:46 Michael Van Canneyt Fixed in Version => 3.1.1
2017-03-19 10:46 Michael Van Canneyt Resolution open => fixed
2017-03-19 10:46 Michael Van Canneyt Target Version => 3.2.0
2017-03-19 11:57 Andrey Zubarev Note Added: 0099057
2017-03-19 11:57 Andrey Zubarev Status resolved => closed